locked
MonoDevelop no longer supports SVN? RRS feed

  • Question

  • User74 posted

    Hi guys, I noticed a while back that the version control options for SVN were removed from MonoDevelop. Any idea when/if they will come back? At the moment Im having to flip into Parallels and commit from TortoiseSVN.

    Cheers John

    Sunday, October 7, 2012 3:59 PM

Answers

  • User9 posted

    Did you happen to update to Mountain Lion at the same time? Apple removed SVN from the default installation so you need to download it manually: http://superuser.com/questions/455214/where-is-svn-on-os-x-mountain-lion

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Sunday, October 7, 2012 11:56 PM

All replies

  • User85 posted

    I still have svn support in MD. Check in "Add-in Manager..." and make sure its not disabled.

    Sunday, October 7, 2012 4:54 PM
  • User85 posted

    Here is a picture of the svn addin

    Sunday, October 7, 2012 4:57 PM
  • User74 posted

    Yep its enabled in Ad-in Manager, but its not seeing the working copy.

    Sunday, October 7, 2012 5:47 PM
  • User9 posted

    Did you happen to update to Mountain Lion at the same time? Apple removed SVN from the default installation so you need to download it manually: http://superuser.com/questions/455214/where-is-svn-on-os-x-mountain-lion

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Sunday, October 7, 2012 11:56 PM
  • User74 posted

    Thanks Chris, exactly right. Installing from XCode fixed the problem.

    Cheers John

    Monday, October 8, 2012 9:32 AM
  • User28610 posted

    I'm having this same issue, on Mac 10.9 (Mavericks). My installation of Xamarin is showing SVN enabled in Add-in Manager but it's not showing up under the main Version Control options so all I can use is Git.

    Here is a screenshot of what my Xcode downloads looks like... I've installed all the dependencies necessary. My SVN version is 1.7.10.

    Anyone else have this issue?

    Saturday, November 16, 2013 6:02 AM
  • User168 posted

    @Martryn

    Probably not installed Xcode Tools Command Lines

    Use the terminal and run this command: xcode-select --install

    Monday, November 18, 2013 3:02 PM