none
Remove a project from the Project Explorer RRS feed

  • Question

  • Hi,

    I accidentally added the wrong DLL to a project. It is not added as a project in the correct way (i.e. File - Add - Existing Project), I honestly don't know what I did, but it was there suddenly. The Explorer still reads Project Explorer and not Solution Explorer, which I would expect when done in the correct way. I know the location of this DLL, as part of an other project. I  searched Forums and internet, but didn't found a way to get rid of this DLL.

    Any help or suggestion is very welcome.

    Kind Regards,

    GerritV2

    Thursday, May 18, 2017 7:44 PM

Answers

  • I sure don't know what is happening. Does this happen when you use "File" | "Open" | "Project/Solution" and then select the "sln" file?

    You can post a screen shot of the "Project Explorer" so we can see that. As best as I can tell, there is no "Project Explorer" in VS 2015 and I assume not in VS 2017. Are you using VS 2015 or VS 2017? I have been using Microsoft's IDEs since before the first version of Visual Studio and back when the IDE was a DOS program. It is strange that it is called "Project Explorer".

    The most likely explanation is that you have an extension. Check to see what extensions you have installed ("Tools" | "Extensions and Updates").



    Sam Hobbs
    SimpleSamples.Info

    • Marked as answer by GerritV2 Saturday, May 20, 2017 7:38 PM
    Saturday, May 20, 2017 6:46 PM

All replies

  • Hi GerritV2,

    Welcome to MSDN forum.

    Normally, we could remove the dll directly like the screenshot.

    >>I know the location of this DLL, as part of an other project.

    I don’t know what happened to you, you could change the location of the dll and then re-add it to your project. If you still meet the issue, please create a new solution, copy your project in it.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, May 19, 2017 6:51 AM
  • There is very much of your question that is not clear. For example you say "The Explorer"; what explorer? I don't understand what you mean by "still reads Project Explorer and not Solution Explorer". You say "there suddenly"; where is "there"? Where do you see the DLL? What type of DLL is it?


    Sam Hobbs
    SimpleSamples.Info

    Friday, May 19, 2017 9:17 PM
  • Hi Simple Samples,

    thanks for your reaction.

    In reply:

    -in short: I had build a solution in VS 2013 update 5 of 2 projects, a VB UI and an Intel Fortran DLL.

    It worked as expected (debug in both projects, build Solution without errors and executed).

    - normally the title of the Solution Explorer read "Solution Explorer (2 projects)", until recently it did so, but a couple of days ago at starting VS the title was changed into "Project Explorer". The DLL was still in the PE's list, but was not recognized as part of a solution.

    - trying to ADD it again to  the UI-project I got the message "DLL is already part of the solution".

    A build of the "UI" project re-compiled the Fortran routine of the DLL,  the post-build event is executed, linked is succesfull.

    But at "Start debug" the error was "VS can not start debug because a debug target is not specifeid".

    With a Solution you can specify which project is start-up; but this option is not in the list of the "Project Explorer".

    My question is "how to re-set the Project Explorer to  the Solution Explorer or set the Start-up project".

    I hope this better explains the problem

     With kinds regards,

    GerritV2

    Saturday, May 20, 2017 9:57 AM
  • I sure don't know what is happening. Does this happen when you use "File" | "Open" | "Project/Solution" and then select the "sln" file?

    You can post a screen shot of the "Project Explorer" so we can see that. As best as I can tell, there is no "Project Explorer" in VS 2015 and I assume not in VS 2017. Are you using VS 2015 or VS 2017? I have been using Microsoft's IDEs since before the first version of Visual Studio and back when the IDE was a DOS program. It is strange that it is called "Project Explorer".

    The most likely explanation is that you have an extension. Check to see what extensions you have installed ("Tools" | "Extensions and Updates").



    Sam Hobbs
    SimpleSamples.Info

    • Marked as answer by GerritV2 Saturday, May 20, 2017 7:38 PM
    Saturday, May 20, 2017 6:46 PM
  • Hi Sam,

    according to MS "project explorer in vs 2013" a Project Explorer" exist in VS 2013

    "to view and manage macros and macro projects in the Macros IDE".

    As far as I know I haven't  called this Macros IDE.

    To remove the file from the project I removed the line in the .snl file.

    Restarting the VS the DLL was gone.

    Restarting VS, initially Vieuw showed the Solution Explorer to open; but opening my project

    this changed into Project Explorer.

    Following the suggestion of RLWA32 on question my "How to restore a Solution"

    The Solution is restored and the program is running again.

    Many thanks for your advice.

    GerritV2

    Saturday, May 20, 2017 7:46 PM
  • Yes, I saw that page about VS 2013. Microsoft dropped support for macros so that is not relevant in 2015 and 2017.

    The important thing is that you got it working.



    Sam Hobbs
    SimpleSamples.Info

    Saturday, May 20, 2017 8:38 PM