locked
Unable to find a version of 'Microsoft.Data.OData' RRS feed

  • Question

  • I am trying to install the new SDK and I am getting:

    Attempting to resolve dependency 'WindowsAzure.Storage (≥ 1.7.0.0)'.

    Attempting to resolve dependency 'Microsoft.Data.OData (= 5.0.2)'.

    Attempting to resolve dependency 'Microsoft.Data.Edm (= 5.0.2)'.

    Attempting to resolve dependency 'System.Spatial (= 5.0.2)'.

    Attempting to resolve dependency 'Microsoft.WindowsAzure.ConfigurationManager (≥ 1.8.0.0)'.

    Attempting to resolve dependency 'Microsoft.Data.Edm (≥ 5.1.0)'.

    Updating 'Microsoft.Data.Edm 5.0.2' to 'Microsoft.Data.Edm 5.1.0' failed. Unable to find a version of 'Microsoft.Data.OData' that is compatible with 'Microsoft.Data.Edm 5.1.0'.

    Weird thing is... I have 'Microsoft.Data.Edm 5.0.2' installed!

    ====================

    So... I tried running (http://nuget.org/packages/Microsoft.Data.OData/)

    PM> Install-Package Microsoft.Data.OData -Pre

    and I got:

    Install-Package : Updating 'Microsoft.Data.OData 5.0.2' to 'Microsoft.Data.OData 5.3.0-rc1' failed. Unable to find a version of 'WindowsAzure.Storage' tha
    t is compatible with 'Microsoft.Data.OData 5.3.0-rc1'.
    At line:1 char:16
    + Install-Package <<<<  Microsoft.Data.OData -Pre
        + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException

    ===========================

    PM> Install-Package Microsoft.Data.Edm -Pre
    You are downloading Microsoft.Data.Edm from Microsoft Corporation, the license agreement to which is available at http://go.microsoft.com/?linkid=9809688. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
    Successfully installed 'Microsoft.Data.Edm 5.3.0-rc1'.
    Install failed. Rolling back...
    Install-Package : Updating 'Microsoft.Data.Edm 5.0.2' to 'Microsoft.Data.Edm 5.3.0-rc1' failed. Unable to find a version of 'Microsoft.Data.OData' that is
     compatible with 'Microsoft.Data.Edm 5.3.0-rc1'.
    At line:1 char:16
    + Install-Package <<<<  Microsoft.Data.Edm -Pre
        + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
        + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
     
    PM>

    Any idea what's wrong?


    • Edited by Rob Vig Wednesday, February 13, 2013 3:21 PM
    Wednesday, February 13, 2013 3:04 PM

Answers

All replies

  • Sounds like typical Assembly dependency binding issue in NuGet.

    Something else you installed has taken a slightly different dependency. See this thread from Nick on setting up Assembly binding in your project and let us know if this helps.

    http://social.msdn.microsoft.com/Forums/en-US/MediaServices/thread/eb05a115-36b2-47a5-b464-3220548a5de9

    Our NuGet package depends on the following versions. Note that OData is 5.1.0 for us, not 5.0.2

    WindowsAzure.Storage (≥ 1.7.0.0)

    Wednesday, February 13, 2013 4:55 PM
  • John,

    First, thanks for responding. I tried to install all of the packages listed above but they all tripped on the same thing regardless of the order I ran them.

    As for the post:

    http://social.msdn.microsoft.com/Forums/en-US/MediaServices/thread/eb05a115-36b2-47a5-b464-3220548a5de9

    I don't have any of this in my web.config...

    <runtime>
       
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
         
    <dependentAssembly>
           
    <assemblyIdentity name="Microsoft.Practices.TransientFaultHandling.Core" publicKeyToken="31bf3856ad364e35" culture="neutral" />
           
    <bindingRedirect oldVersion="0.0.0.0-5.1.1209.0" newVersion="5.1.1209.0" />
         
    </dependentAssembly>
         
    <dependentAssembly>
           
    <assemblyIdentity name="Microsoft.WindowsAzure.StorageClient" publicKeyToken="31bf3856ad364e35" culture="neutral" />
           
    <bindingRedirect oldVersion="0.0.0.0-1.7.0.0" newVersion="1.7.0.0" />
         
    </dependentAssembly>
         
    <dependentAssembly>
           
    <assemblyIdentity name="Microsoft.Data.Services.Client" publicKeyToken="31bf3856ad364e35" culture="neutral" />
           
    <bindingRedirect oldVersion="0.0.0.0-5.1.0.0" newVersion="5.1.0.0" />
         
    </dependentAssembly>
       
    </assemblyBinding>
     
    </runtime>

    My project consists of 1 Web Role, that's it. Where else could this stuff be?

    Thank you,

    Robert


    • Edited by Rob Vig Wednesday, February 13, 2013 7:17 PM
    Wednesday, February 13, 2013 7:17 PM
  • I have the same problem and I think that the problem is between WindowsAzure.Storage and WindowsAzure.MediaServices.

    WindowsAzure.Storage needs Microsoft.Data.OData version 5.0.2 and MediaServices needs version 5.1.0 or higher.

    I am new to this so I would like to know the solution.

    Friday, February 15, 2013 4:01 PM
  • As hijdrofiel mentioned, there is a conflict between the targeted version of the Microsoft.Data.OData dependency in the WindowsAzure.Storage (2.0.4.0) and WindowsAzure.MediaServices (2.0.1.0) NuGet packages. That's why the installation is failing.

    Despite this installation error, the current version of the Media Services Client SDK requires the Storage Client Library 1.7 (WindowsAzure.Storage 1.7.0.0) to upload/download asset files, and does not support the latest version (2.0) of the library (WindowsAzure.Storage 2.0.4.0). The reason is that the Storage Client Library 2.0 is not backwards compatible with the previous 1.7 one. It is a totally different assembly (you can check the breaking changes here), so changing the assembly bindings won't work.

    If you need both WindowsAzure.Storage and WindowsAzure.MediaServices packages in your project, I recommend you to just install the WindowsAzure.MediaServices one because it already depends on the WindowsAzure.Storage package (but in a previous version - 1.7.0.0).

    Hope this helps,

    Mariano Converti - http://blogs.southworks.net/mconverti/




    Friday, February 15, 2013 5:10 PM
  • Mariano is correct.  Media Services .NET SDK does not currently support or work with the latest WindowsAzure.Storage client 2.0 or greater.  They changed a lot of things in that version of the library and most changes are breaking changes.  

    If you are working with Media Services, you need to use the WindowsAzure.Storage 1.7.0.0 package.

    We will be upgrading the NET SDK to Storage 2.0 in a future release. I can't provide the timing of that at this time.

    Friday, February 15, 2013 5:36 PM