locked
Users can not open a form RRS feed

  • Question

  • System:
        MOSS 2007
        InfoPath 2007

    Access:
        Site Collection Administrator

    I have created an InfoPath form that retrieves two lists from SharePoint (list of users, and list of training sessions); these are two Data Connections set to "Retrieve".

    I have a third Data Connection that is set to "Submit".  This submits several of the InfoPath fields to the SharePoint Document Library, as well as the completed form.  The InfoPath form is published to this document library, so when users choose "New" in the document library, the InfoPath template (form) will appear, to allow the user to complete the form.

    I can open the form, complete it, and submit it.  No problem.

    Other users cannot open the form.  They are getting prompted for User Name and Password.  If they cancel out of that, and the next popup (about working offline), the InfoPath form will appear without any data connections.  The User Name/Password error refers to the _vti_bin\lists.asmx.

    Users have Contribute rights to the document library.

    Anyone have any ideas to get this form to open for the users?  If more details are needed, please just ask for what you would like to know.

     

    Thank you,

        Chris Kiel


    • Edited by Mike Walsh FIN Monday, April 4, 2011 1:39 PM "SharePoint and InfoPath" (original Title) is not a problem description
    Monday, April 4, 2011 1:25 PM

Answers

  • Sounds like the users don't have access to the two SharePoint lists, right?  The form is querying those lists, so the users must be able to read from those lists.  Getting prompted for credentials is what happens when you don't have access to something in SharePoint, and the fact that InfoPath told you it would have to work offline due to not being able to access the data connections kind of seals the deal...
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Chris Kiel Tuesday, April 5, 2011 8:23 AM
    Tuesday, April 5, 2011 5:29 AM

All replies

  • Sounds like the users don't have access to the two SharePoint lists, right?  The form is querying those lists, so the users must be able to read from those lists.  Getting prompted for credentials is what happens when you don't have access to something in SharePoint, and the fact that InfoPath told you it would have to work offline due to not being able to access the data connections kind of seals the deal...
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Chris Kiel Tuesday, April 5, 2011 8:23 AM
    Tuesday, April 5, 2011 5:29 AM
  • That was it.  I added reference to the two lists after the initial form build.  The two lists were restricted to the "Admins", thus the users were getting the User Name / Password popup.  I figured it was right there in front of me, but been working on this site for a week, and just missed that.  Thanks for the assistance and sanity check.
    Tuesday, April 5, 2011 8:25 AM