locked
VS2008 Final Release - Visual Studio Conversion Wizard Error - COMException RRS feed

  • Question

  • User-798470829 posted

     I get.....

    ---------------------------
    Visual Studio Conversion Wizard Error
    ---------------------------
    System.Runtime.InteropServices.COMException
    ---------------------------
    OK  
    ---------------------------

    ...for 3 out of 5 ASPNet projects in my solution.

    Where can I go to find out more...

    Tuesday, November 20, 2007 6:00 AM

Answers

  • User-1363174918 posted

    OK, it seems to be Vista specific issue with IIS7. VS is unable to verify if you have access to the IIS7 metabase. Make sure IIS is installed with IIS6 compat and you have admin rights. Try running VS as admin - see if it helps.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, November 20, 2007 7:02 PM

All replies

  • User1357443054 posted

    Same problem here. The upgrade log says:

    Project converted successfully
    System.Runtime.InteropServices.COMException 

    If I try to re-open the project, the conversion wizard is started again with the same result. The respective project is a VS 2005 Web application project. Any help is appreciated. 

     

     

     

    Tuesday, November 20, 2007 1:02 PM
  • User1357443054 posted

    I now suceeded in converting my solution just fine by using a second installation on my backup dev system running XP SP2 (my main dev machine runs Vista Ultimate). BUT: Once I check out the updated solution on the first machine and try to open the solution in VS 2008, I get the same System.Runtime.InteropServices.COMException as above. On my XP machine I can open the converted solution in VS 2008 without any problems and do everything I like with it.

    Two possible explanations:

    - On my main machine I had VS 2008 Beta2 installed before, but not on the other one. I completely deinstalled it before I installed RTM, but maybe there are some left-overs (especially as the deinstall crashed at some point) ? 

    - A Vista problem.
     
    Any ideas ?

     

    Tuesday, November 20, 2007 2:34 PM
  • User-1363174918 posted

    Can you obtain minidump of the exception, zip it and e-mail it to me? Basic steps are here: http://blogs.msdn.com/mikhailarkhipov/archive/2006/07/25/678308.aspx

    After step #6, go to Debug | Exceptions and check CLR Exceptions | System.Runtime.InteropServices.COMException. Then proceed with step #7.

    Tuesday, November 20, 2007 3:12 PM
  • User-798470829 posted

    I can confirm that the machine which now holds VS2008 for me, has at no time in the past held a prerelease copy of "anything".

    I am however running Vista Ultimate 64-bit edition ( 4gigs Ram)


     

    Tuesday, November 20, 2007 3:32 PM
  • User-798470829 posted

    Will do... I'll be right back..

    Tuesday, November 20, 2007 3:33 PM
  • User1357443054 posted

    Mikhail,

    thanks for your help ! I tried several times creating a crash dump as described in your blog and your email. However, all I am getting is a message box in the VS 2008 instance being debugged saying "System.Runtime.InteropServices.COMException". In the debugging instance I can see an exception occurring in the output window:

    First-chance exception at 0x7697b09e in devenv.exe: 0xE0000002: 0xe0000002.
    First-chance exception at 0x7697b09e in devenv.exe: 0xE0000002: 0xe0000002.

    But that's it. I don't get a chance to capture the crash dump in the second instance of VS, as everything just runs on fine (apart from the error message and my project not being opened). Am I doing something wrong ? I checked "System.Runtime.InteropServices.COMException" "Thrown" in "Debug" "Exceptions" as you wrote above.

    Best regards,

    Chandra 

     

     

    Tuesday, November 20, 2007 3:37 PM
  • User-798470829 posted

     Erm... I cannot see an option to "Debug...Save Dump"....

     Where can I go to turn such an option on?
     

    Tuesday, November 20, 2007 3:40 PM
  • User-1363174918 posted

    If you don't see the option, you either have Web development profile set in the UI and/or no C++ installed. Try selecting General Development in Tools | Import/Export Settings.

    Tuesday, November 20, 2007 3:49 PM
  • User-1363174918 posted

    Perhaps 'Just My Code' is set. Try unchecking 'Enable Just My Code' in Tools | Options | Debugging.

    Tuesday, November 20, 2007 3:50 PM
  • User-798470829 posted

    Nah I was just being too quick and forgot to request native & managed (It defaulted to Managed + TSQL).

    So I've got a Minidump.zip waiting to go. How do I get it to you... I can't find an email address or an option to attach a file to this post
     

    Tuesday, November 20, 2007 3:55 PM
  • User1357443054 posted

     Same with me (the "My Code" thingy did it). I got the dump, but where do I send it ? The forum's mail function seems not to allow for attachments.

     

     

    Tuesday, November 20, 2007 3:57 PM
  • User-1363174918 posted

    Oh, sorry. mikhaila-at-microsoft-dot-com

    Tuesday, November 20, 2007 3:58 PM
  • User-798470829 posted

    I Should'a guessed really. Email sent.

     

    Thanks very much for your help in this Mikhail 

    Tuesday, November 20, 2007 4:00 PM
  • User1357443054 posted

     Email is on its way. Thanks again !

    Tuesday, November 20, 2007 4:06 PM
  • User-1363174918 posted

    Do you have Web Deployment Project as part of the solution with WAP?

    Tuesday, November 20, 2007 5:05 PM
  • User-798470829 posted

    No... No Deployment app in my case... Several Class Libraries, a DB Project and a webservice.

    Tuesday, November 20, 2007 5:19 PM
  • User-798470829 posted

     Just noticed.. there is also a console app for testing purposes.

    Tuesday, November 20, 2007 5:25 PM
  • User1357443054 posted

     Also no Web deployment project with me. The solution consists of a Web application project (the troublemaker) and several class libraries which were converted without any problems on both machines.

    Tuesday, November 20, 2007 5:55 PM
  • User-1363174918 posted

    OK, it seems to be Vista specific issue with IIS7. VS is unable to verify if you have access to the IIS7 metabase. Make sure IIS is installed with IIS6 compat and you have admin rights. Try running VS as admin - see if it helps.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, November 20, 2007 7:02 PM
  • User-798470829 posted

     Perfect Answer.

     

    Once I ran Studio with full admin, it revealed that the 3 projects suffered the same problem.

    All 3 were set to run using IIS instead of the builtin Webserver. And all 3 had IIS pointing at different directories than those that the projects were located in.

    This is because (Being a little careful occasionally) I copied the solution folder before trying out VS2008 but forgot to tell IIS.

    After I changed the virtual directories to point at the new locations, I was able to run Studio in non admin and everything went through prefectly.

    I will test properly in the morning but as far as I am concerned this is fixed.

    I will until after the morning's tests and also to hear from wait to hear from Wudbaer before I mark the post as an answer but I'm very happy with this.

     

    Great stuff Mikhail. Thanks very much indeed :D

    Tuesday, November 20, 2007 9:33 PM
  • User-798470829 posted

     Ok I was talking out of my ****. It's late... I didn't change Studio back out of Admin mode before rerunning the test.

    However my solution now appears to be good.

    I have since changed my apps to not use IIS and the conversion does indeed complete withour admin.

    Following this, I tried to change 1 back to IIS and as I did I got  a warning saying that I couldn't do this withour running in Admin mode.

    This seems to complete the pattern.

    It seems a shame that this continues to be the case even in 2008. but I can live with it :)

     

     

    Tuesday, November 20, 2007 9:44 PM
  • User-1363174918 posted

    Cool, glad you are all set. The issue with admin mode is not VS bug really, it is rather catch 22. Access to IIS metabase is closed to regular users for security reasons. So VS cannot get access unless you run as admin. It is rather difficult to separate data only needed by VS and only needed at IIS runtime.

    Wednesday, November 21, 2007 12:00 AM
  • User-798470829 posted

     

    The issue with admin mode is not VS bug really, it is rather catch 22. Access to IIS metabase is closed to regular users for security reasons. So VS cannot get access unless you run as admin.

    I mostly agree and I certainly understand.

    The "bug" is in the fact that VS does not recognise that it does not have access and explain what is needed.
    Ideally it should activate UAC and ask for permission to access the information required or state that the error is because it has insufficient permission to access some IIS meta data. And that a valid alternative might be to switch to using the internal web development server.

    Wednesday, November 21, 2007 5:16 AM
  • User1357443054 posted

    This information also fixed it for me ! I now started VS2008 with "Run as Administrator" and everything worked like a charm: The project got opened, IIS was configured accordingly, and I can compile and debug the project, so from were I'm standing it is also fixed. Thank you very much again, Mikhail !

     
    Best regards,

     
    Chandra 

    Wednesday, November 21, 2007 5:58 AM
  • User-1363174918 posted

    It is true. I already opened a bug about providing better experience. The code does show explanation is several cases, but apparently missing a few.

    Wednesday, November 21, 2007 10:31 AM
  • User-751292108 posted

    I think the problem may be related to the IIS Virtual Directory of the Web Application.  First use INETMGR.EXE to ensure the virtual directory of the web application is set up correctly.  Second, on Vista make sure your run VS with Administrator privilages (ie right click Run As Administrator.)  Third, now try to open and migrate the solution.  Let us know if this helps.

    Monday, November 26, 2007 3:43 PM
  • User-798470829 posted

    I believe we have already each indicated that our migration went very smoothly as soon as we loaded vs using "Run as Administrator"

    The remaining issue is really for those users out there who have not located this thread and may perform a similar action at some future point.

    VS does not indicate that it requires said Admin privilages for this operation. Rather it's conversion process fails with a COMException which is less than useful.

     
    I'm not sure what further information we can give you
     

     

    Tuesday, November 27, 2007 5:38 AM
  • User72259518 posted

    We had the same problem here.. Me running xp iis6 and the other developer on the project running Vista iis7.
    (I use localhost as path to iis, he uses a custom hostheader for the project) 

    Every time i opend the project from subversion i got the same error..

    Project loaded fine when I removed then 'bottom' section in the vbproj file. Right click on the project unable to load and click 'edit project file'. The file is loaded into an text editor..

    Then i clicked reload projet( it now loads)..
    UnChecked the "Apply server settings..." checkbox in properties|Web for the project, and removed the xxx.vbproj.user file from subversion..

    Now it works.. [:D]

     

    Friday, November 30, 2007 3:24 AM
  • User1368669297 posted

    This is due to IIS problem, under VISTA system, IIS7 is used, but probably in your old system, you used IIS6.

    So be sure you also have "IIS6 management compatibility" tools installed in your VISTA system.

    How: Control Pannel -> Programs and Features -> Turn Windows Features on or off -> IIS -> Windows management tools

    Tuesday, January 8, 2008 4:53 AM
  • User36599481 posted

     I had a similar issue, but in slightly different circumstance. I was working on a new machine (Vista SP1) that didn't yet have IIS even installed.

    When I went to upgrade the web project, I got this error. Running as Admin did not fix the issue, but thanks to the suggestions in this forum, it pointed me to the fact that the upgrade was trying to access the IIS application linked in the web project. That didn't exist on my machine, and thus the error.

    My solution was to create a new web project that ran inside the visual studio web server. I then compared and merged the new web project's settings with the old web project.

    This effectively changed the old webproject to run in the vs web server instead of (the missing) IIS. I then re-ran the upgrade and it completed flawlessly.

     I do agree that the user experience on this issue could be improved. My user experience was sufficient only because it happened to include this forum :D
     

    Wednesday, April 9, 2008 12:29 PM
  • User1080916067 posted

    I know I'm late but I met this problem too under vista because i just forgot to run VS as administrator (shortcut right click / run as administrator)

    Hope this will help someone.

     

     

     

    Thursday, November 13, 2008 10:18 AM