none
A4Swift configuration wizard not running after installation complete RRS feed

  • Question

  • I am installing accelerators (A4Swift) for biztalk server 2009, however, when the installation complete, the configuration wizard does not run. There is even no option for "Run configuration wizard". Anyone can help? Thanks.

    Tuesday, January 19, 2016 2:41 AM

Answers

  • Uninstall and install many times, the Run configuration wizard check box not showing.

    This is not going to take you any where.

    You have to take some time out at read the  Installing BizTalk Server 2009 Accelerator for SWIFT guide.

    You must install the same edition of A4SWIFT as your BizTalk Server 2009 installation.

    A4SWIFT Enterprise can be installed on BizTalk Server 2009 Enterprise and Developer edition.

    A4SWIFT Standard can be installed on BizTalk Server 2009 Standard edition. 

     

    Each SWIFT Accelerator version must be installed with the appropriate BizTalk Server version.

    BizTalk Server version

    SWIFT Accelerator version

    BizTalk Server 2009

    A4SWIFT 2009


    Because a successful A4SWIFT installation is dependent on a properly installed/configured BizTalk Server 2009, you must review and follow the installation documentation for BizTalk Server 2009.  


    • Proposed as answer by Angie Xu Tuesday, February 2, 2016 2:09 AM
    • Marked as answer by Angie Xu Tuesday, February 2, 2016 2:09 AM
    Tuesday, January 19, 2016 11:40 AM
    Moderator

All replies

  • I am installing accelerators (A4Swift) for biztalk server 2009, however, when the installation complete, the configuration wizard does not run. There is even no option for "Run configuration wizard".

    Where have you checked for the option? It is definitely not on the screen. It is available as a menu option under the "BizTalk Server Accelerator for SWIFT" Group option. The Accelerator configuration wizard (unlike the BizTalk Configuration Wizard) will not invoke itself (and as you've seen, there is no option on the completion screen).

    The configuration populates the Message Repair Service in addition to creation of the A4SWIFT Database which can be leveraged to upload BIC+, etc. The Message Pack comes with its own configuration which is essential for ACK/NAK processing and a few other things.

    So look for Menu GROUPS "BizTalk Server Accelerator for SWIFT" and another group specifically for the Message Pack. BOTH have configurations which should be run after installation.

    Regards.

    Tuesday, January 19, 2016 4:38 AM
  • Have installed all except documents, but still cannot see any configuration option in Menu Groups.

    Tuesday, January 19, 2016 5:26 AM
  • Hi,

    have you followed the Installing BizTalk Server 2009 Accelerator for SWIFT guide?

    Please ensure you have all the prerequisites covered.

    Also, you can try:

    • Make sure SSO and BizTalk are installed and configured properly
    • Use domain users and groups while installaing BizTalk and A4SWIFT. Ensure that same domain user have proper rights at SQL Server level.
    • Manually deploy A4SWIFT assemblies using BTSDeploy.exe

    Refer the link: A4SWIFT Properties missing

    Tuesday, January 19, 2016 6:18 AM
    Moderator
  • It is possible that you've the wrong version of the Accelerator ?!? The Accelerators are available on the BizTalk Installation Media under the Accelerators folder.

    The other reason I suspect this is because I do not see any Message Pack installed. The CORRECT Accelerator for BizTalk 2009 will also install the SWIFT Message Pack 2009 which is a separate menu group.

    Regards.

    Tuesday, January 19, 2016 7:08 AM
  • Anyone can tell me the program name for the configuration wizard, so that I can manually run it to complete the configuration?
    Tuesday, January 19, 2016 7:35 AM
  • It seems accelerators (A4Swift) got installed partially , due to this you are unable to see the Run configuration wizard check box in accelerator A4 swift installation wizard.

    Follow the below steps to see Run configuration wizard check box

    Uninstall accelerators (A4Swift) ,which has installed earlier, and install it again ,this time may be you can able to see the Run configuration wizard check box .here you need to select the check box to configure the A4 Swift accelarator .







    Tuesday, January 19, 2016 9:38 AM
  • Uninstall and install many times, the Run configuration wizard check box not showing.
    Tuesday, January 19, 2016 10:26 AM
  • Uninstall and install many times, the Run configuration wizard check box not showing.

    This is not going to take you any where.

    You have to take some time out at read the  Installing BizTalk Server 2009 Accelerator for SWIFT guide.

    You must install the same edition of A4SWIFT as your BizTalk Server 2009 installation.

    A4SWIFT Enterprise can be installed on BizTalk Server 2009 Enterprise and Developer edition.

    A4SWIFT Standard can be installed on BizTalk Server 2009 Standard edition. 

     

    Each SWIFT Accelerator version must be installed with the appropriate BizTalk Server version.

    BizTalk Server version

    SWIFT Accelerator version

    BizTalk Server 2009

    A4SWIFT 2009


    Because a successful A4SWIFT installation is dependent on a properly installed/configured BizTalk Server 2009, you must review and follow the installation documentation for BizTalk Server 2009.  


    • Proposed as answer by Angie Xu Tuesday, February 2, 2016 2:09 AM
    • Marked as answer by Angie Xu Tuesday, February 2, 2016 2:09 AM
    Tuesday, January 19, 2016 11:40 AM
    Moderator
  • I think the A4SWIFT installer requires that BizTalk Application 1 (the default Application created during BizTalk Configuration) exist.

    If you removed BizTalk Application 1, re-add it before running Setup again.

    Tuesday, January 19, 2016 3:45 PM
    Moderator
  • It is called "Configuration.exe" and will be available in the Accelerator for SWIFT folder. I would still request that you check the version of A4SWIFT installed which IMHO is not correct.

    Regards.

    Wednesday, January 20, 2016 5:53 AM