locked
Credential picker - WinRTError: The remote procedure call failed

    Question

  • When I use Windows.Security.Credentials.UI.CredentialPicker.pickAsync i get the following error:

    "The remote procedure call failed."

    The full error is shown in the image below:

    credential picker error

    The code in the image is taken from the credential picker sample. I have only added the function(err) function to the sample code.

    Is this a new bug with WinRT? or has something changed?

    I found it when my app started to fail when using the credential picker. It worked before, not sure why it fails now. Could it be a bug introduced with an update to WinRT?

    To replicate the error:
    - Download the credential picker sample.
    - Try to do scenario 1 (Message Only).
    - If you don't see anything in the output fields after running the sample. Then you probably have the same error.
    - To see the error message: add function(err){ }, as in the picture above, to the crendentialPicker.pickAsync promise.

    Monday, April 08, 2013 11:22 AM

Answers

All replies