locked
How to disable the Edi Data Validation RRS feed

  • Question

  •  

    Hi Everybody!!

     

    I am getting many errors related to mandatory data element missing and Invalid code values from Incoming EDI Messages.

     

    So I can not handle the values in inbound messages. I know that the incoming messages will use the 426 schema only.

    So I want to disable the Edi Validation in order to turn off the validation of field length, optionality, and repeat count in addition to EDI data element validation.

     

    The "EdiDataValidation" property was set to false in my receive locations but Biztalk still is doing the validation.

    http://msdn.microsoft.com/en-us/library/bb727675.aspx

     

    Do you know how to disable the EdiValidation?

    Thanks in advance

    Pablo

     

    SegmentID: BX

    Position in TS: 6

    Data Element ID: BX03

    Position in Segment: 3

    Data Value:

    1: Mandatory data element missing

    Wednesday, June 11, 2008 2:22 PM

All replies

  • Try disabling it for that party in PAM (partner agreement manager).

    JT

     

    • Proposed as answer by Bhava Tuesday, September 15, 2009 10:37 PM
    Wednesday, June 11, 2008 4:19 PM
  • got the similar issue.., as JT77 said, disable validations in PAM. Thanks JT77.

    Here is little more info on PAM(if anyone got into similar problem)

    Global EDI property (right click on "Parties" select "EDI Properties") and Party specific EDI property (right click on party, select EDI Properties)  UI pages are called Partner Agreement Manage,PAM. (http://msdn.microsoft.com/en-us/library/dd802467(BTS.10).aspx)

    To disable validations for a party for sending EDI documents, right click on Party, select EDI Properties, under X12 properties, Party as Interchange Receiver,ACK Processing and Validation Settings, uncheck "EDI Type"(may be other check boxes also based on your requirement)

    Thanks
    Kishore

    Tuesday, September 15, 2009 10:36 PM
  • Hi,
        If you are doing any EDI transaction you should not disable edi validation. After disabling it , It will not validate any EDI document type.


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, September 16, 2009 5:40 PM