locked
Gembox show spreadsheet RRS feed

  • Question

  • User113730038 posted

    I am unable to find a Gembox forum so I hope someone here can help.  I am able to run locally and the export works and the spread sheet displays.  When I deploy to the server and run it there, nothing gets displayed but it is saved to the server (not locally).  Here is my code and the error I get (the file IS there): 

    Error With LogError - Export To Excel Error: Input directory "\\serverfolder\share\Temp\QualityWaiverReport\myfile.xlsx" does not exist. at GemBox.Spreadsheet.ExcelFile.LoadXlsxFromDirectory(String path, XlsxOptions xlsxOptions) at _Default.ExportToExcel()

    ObjExcel.SaveXlsx(FileName)

    ObjExcel.LoadXlsxFromDirectory(FileName, XlsxOptions.None)

    Thursday, August 20, 2015 8:05 AM

All replies

  • User-219423983 posted

    Hi skister77,

    Error With LogError - Export To Excel Error: Input directory "\\serverfolder\share\Temp\QualityWaiverReport\myfile.xlsx" does not exist. at GemBox.Spreadsheet.ExcelFile.LoadXlsxFromDirectory(String path, XlsxOptions xlsxOptions) at _Default.ExportToExcel()

    According to the error message above, you could first check whether the excel file exists and whether you could access the file through the file path in server side. If true, you could refer to the following first link to grant the identity correct permissions. About how to get the identity in your web site, you could refer to the second link.

    https://support.microsoft.com/en-us/kb/207671

    http://www.iis.net/learn/manage/configuring-security/application-pool-identities

    I hope it’s useful to you.

    Best Regards,

    Weibo Zhang

    Thursday, August 20, 2015 11:04 AM
  • User113730038 posted

    I am able to get to the file on the server via localhost and by Explorer and the file is there.  I am not sure what settings to set for IIS (7.5).  All authentication is set to disabled except windows authentication.  Is there other parameters I need to check?

    all I need to do is to display the spreadsheet.

    Thursday, August 20, 2015 11:44 AM
  • User-219423983 posted

    Hi skister77,

    You could refer to the following two thread to achieve your need. When you run it locally (do you means when you debug it on your local machine), it would use the administrator or the current user to access the network shared file. When you deploy this application to IIS, the ApplicationPool identity also needs access to the shared file. For more things, you could refer to the following links.

    http://forums.iis.net/t/1175002.aspx

    https://grekai.wordpress.com/2011/05/23/permissions-for-shared-folder-for-iis-7-application-pool-identity-across-domain/

    I hope it’s useful to you.

    Best Regards,

    Weibo Zhang

    Thursday, August 20, 2015 11:11 PM
  • User113730038 posted

    tried those and the folders are locked down.  What I did that did work was to put a hyperlink to the spread sheet and that works.  Thanks for trying to help.

    Friday, August 21, 2015 9:20 AM