none
MySites WebApplication and credential request repeated RRS feed

  • Question

  • Hi,

    I have an intranet with the mySites on the same Web Application.

    If I create the mysites host on a diferente web application it seems that when the user uses a browser diferent from IE,  he will be prompted to reenter his credentials when navigating from the intranet portal webApplication to MySites web Application.

    Is there a way to avoid this credentials  repetition by the user?

    what appends to the information that allready exists for that users (social activity). Will it be lost or have I a way to migrate it?

    Help is really appreciated.

    Thank you so much,

    JD

    Wednesday, February 1, 2017 7:03 PM

All replies

  • The only way to avoid the second prompt is to either use IE (on a domain joined machine with the proper Internet security zone settings) or to put the MySites on the same Web application.  Authentication is handed off to IIS which handles it at the web site (web application) level.  So if the sites aren't in the same web application you will get prompted.

    If you make sure to migrate the existing user profile databases to the new setting they should retain all the info.


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Wednesday, February 1, 2017 8:34 PM
  • Hi,

    Any update?

    If Paul's reply helps you, please mark the reply as answer, it will make others who stuck with the similar issue easier to search for valid solutions in this forum.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 8, 2017 9:20 AM
    Moderator