locked
Crawling exchange public folders RRS feed

  • Question

  • I am trying to crawl exchange public folders. The content source has been created, but nothing is crawled. The default content access account definitely has permissions to read the folders.

    I do get 1 error but im not quite sure what im missing:

    "A component required for crawling this type of content is not registered with this application server"

    Any help is much appreciated.

    Tuesday, March 8, 2011 11:29 AM

All replies

  • Hi Rich090,

     

    From your description, you encountered the following error when your index server crawled Exchange public folder.

     

    "A component required for crawling this type of content is not registered with this application server"

     

    What is your Exchange server’s and Service Pack versions? Is it Exchange server 2007 or 2010?

    How did you grant permission on the public folder? What permission did the crawl account have?

    Did you enable SSL on the public folder?

     

    If it were Microsoft Exchange 2007 SP2 and later versions, please open a Web browser and navigate to the Outlook Web Access Web page for the Exchange Server that has the public folders that you want to crawl. Log on to Outlook Web Access using the crawl user account, click public folder, make sure you can access the public folder.

     

    Second, the start address look like as the follows:

     

    https://aps.mail.microsoft.com/owa/?ae=Folder&t=IPF.Note&id=PSF.LgAAAAAaRHOQqmYRzZvIAKoAL8RaAwBn8gtOTf5EQp6xnKauojhiAAAAbQf7AAAB&pspid=_1299635961898_458461902

    Apart from that, please make sure your steps of adding content source are correct. for the detailed information about the steps, please see the following link:

     

    http://technet.microsoft.com/en-us/library/ee806927.aspx

     

    If it were Exchange Server 2007 and earlier public folders and you enabled SSL, please refer to the following article:

     

    http://lambertqin.wordpress.com/2009/11/05/crawling-exchange-server-2007-public-folders-in-sharepoint-server-2007-part-2/

     

    Finally, please look into the Event log and post the relevant error into the forum.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Tuesday, March 15, 2011 7:15 AM
  • Thanks for your reply.

     

    The public folder are on Exchange 2003 SP2.

    We crawled the public folders with no issues from MOSS 2007, the issue has only arisen now we are trying to do it from 2010.

    The account has been granted full read permissions.

    Thanks

    Rich

    Wednesday, March 16, 2011 10:21 AM
  • Hello Rich,

    Please take a look at the below Technet article that describes the proper steps for crawling Exchange Public Folders with MSS 2010. Note that there are two procedures listed that describe separate processes to add a content source based on the Exchange Server version. The first procedure describes how to add a content source for Exchange Server 2007 and earlier with which you may want to compare your setup. http://technet.microsoft.com/en-us/library/ee806927.aspx

    Thanks,
    Manas

    Monday, April 18, 2011 10:05 AM