locked
VS 2008 Web Deployment MSI built on XP works fine, but MSI built on Windows 7 does not work RRS feed

  • Question

  • User-1370646108 posted

    I'm running into a weird issue that I can't find an answer for anywhere I've looked (and I've looked a ton).

    I built a web deployment project with Visual Studio 2008 Team System on my old Win XP machine. This has always worked flawlessly and installed everywhere. I can also copy this MSI to my new Windows 7 Ultimate machine and it again installs just fine.

    HOWEVER, when I rebuild that exact same web deployment project on my new Win7 machine, also using VS2008, the MSI will build OK, but when I then run it to install my software I get a dialog box telling me "the installer was interrupted." Interestingly, when I built this MSI in my new environment one additional warning popped up during the build process, which was "Unable to copy the schema file '(null)'"

    After many searches and reading different web pages, I know this has to do with these two registry keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Deployment\Schema]
    "DefaultMSISchemaFile"="c:\\Program Files\\Microsoft Visual Studio 9.0\\Common7\\Tools\\Deployment\\Vspkgs\\..\\VsdSchema\\Schema.msi"
    "DefaultMSMSchemaFile"="c:\\Program Files\\Microsoft Visual Studio 9.0\\Common7\\Tools\\Deployment\\Vspkgs\\..\\VsdSchema\\Schema.msm"

    Yet, everything checks out. All permissions are correctly configured, etc., etc.

    Then, when I enable the built-in administrator account and log in as that, and then rebuild this same web deployment MSI the "Unable to copy the schema file '(null)'" warning no longer appears. Then when I log back out, log back in as myself and then run this newly built MSI it installs fine, just like the original one that was built on XP.

    I also tried uninstalling VS2008 and re-installing it as the super user, but that also didn't change anything. And yes, I did also configure devenv.exe to run as administrator.

    Has anybody seen this? Or is it a requirement that you can only compile deployment projects as the super user? That cannot be right.

    I've been thrashing for more than five days and for the life of me cannot figure this out. Of course, I can run as the super user when developing, but I thought the new security model in Win7 was designed exactly so you don't have to.

    Any wisdom or help would be MUCH appreciated.

    Thanks,
    Rodger

    Wednesday, March 24, 2010 11:38 AM

Answers

  • User-1659704165 posted

    Hi,

    right click on MSI-->Click run administraton abd then Try


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 25, 2010 2:01 AM

All replies