The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure Active Directory!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

Publisher Domain verification fails because "Verification of publisher domain failed. Error getting JSON file from https://{publisher_domain}/.well-known/microsoft-identity-association. The server returned an unexpected content type header value. [f566g]" RRS feed

  • Question

  • I'm trying to verify the publisher domain of my application but it's not working despite the json file being available when checking the link in a browser.https://{publisher_domain}/.well-known/microsoft-identity-association.

    The instructions ask for the json file being hosted at https://{publisher_domain}/.well-known/microsoft-identity-association.json. I get the following error message:
    Verification of publisher domain failed. Error getting JSON file from The server returned an unexpected content type header value. [vquV0]

    Does anyone know what can be the problem? 

    Monday, July 29, 2019 1:30 PM


All replies

  • Hey Swydo,

    We're currently looking into this. It seems that multiple people are having problems with verifying their domain.

    Once we have an update I'll post it accordingly. If you could email :

    With a reference to this thread, I can enable a one time free support ticket for this issue.

    Please also include your subscription GUID, in the email. 

    And if you could also please provide the support ticket # to me I can follow up and make sure that this is addressed.


    - Frank Hu

    Monday, July 29, 2019 11:27 PM
  • I am also getting this same exact error:

    Verification of publisher domain failed. Error getting JSON file from https://{domain}/.well-known/microsoft-identity-association. The server returned an unexpected content type header value. [Cp7mr]

    Friday, August 2, 2019 1:12 PM
  • Hello Nightsurgex3, please email teh azcomunity alias, and with your sub GUID and a reference to this thread. And I'll enable a one time free support ticket. 

    This also goes for anyone else reading this thread. Thanks! 

    Friday, August 2, 2019 5:07 PM
  • I've also just gotten this error.  I've made the json available without the .json extension which is how it's displayed in the error message but it hasn't helped.

    I've emailed


    - Caleb

    Friday, August 9, 2019 5:47 PM
  • Still not solved.
    Saturday, August 10, 2019 12:58 PM
  • Hey Murat, sorry to hear that. Unfortunately this looks like an issue with the the domain verification. Please follow the marked answer, if you email that alias and request a support ticket with your subscription guid, a screenshot of the error, and a reference to this thread we should be able to get someone dedicated to help you with this issue.


    - Frank

    Tuesday, August 13, 2019 10:58 PM
  • Hello All,

    I'm updating this thread now as this issue seems to have been mitigated. 

    It turns out the reason this issue is occurring is because the content type header needs to be exactly : 



    application/json; charset=utf-8

    or some other content header type.

    For those who are experiencing this issue, could you please try this and let us know the result? 

    This is now documented in the link below.

    I apologize again for the inconvenience this has caused everyone. 

    Monday, August 26, 2019 3:42 PM
  • This is very limiting.

    for instance: Github Pages Hosting cannot be used as they always send "charset=utf-8" as Content Type in header

    • Edited by IdeaRoots Monday, September 16, 2019 9:09 AM
    Monday, September 16, 2019 9:09 AM
  • Hey IdeaRoots, 

    I apologize for the inconvenience, and understand that this is a limiting feature that has the ability to cause issues with different implementations. 

    We're currently working to fix this as soon as possible.

    - Frank Hu

    Tuesday, September 17, 2019 12:43 AM
  • I think this note needs to be included in the instructions in the Azure portal pane, or the instructions should be removed and replaced with a link to this documentation. The documentation is not linked and the instructions are shown and seem clear, so there is no reason to go looking for this documentation until verification fails.
    Tuesday, October 8, 2019 2:38 PM
  • Hey Christi S,

    This is in the documentation now, there is a note that says you have to utilize application/json.

    Tuesday, October 8, 2019 5:06 PM
  • I am also linking this github issue, as it is the same error message, but it's a different issue. 

    Please see :

    Tuesday, October 8, 2019 5:30 PM
  • Content-Length is also required and the dashboard doesn't tell you this until you've fixed the content-type header. It is also not mentioned in the documentation linked above.

    Verification of publisher domain failed. The JSON file located at has a content length that is not set or otherwise invalid. [Cit/3]

    Wednesday, October 9, 2019 3:42 PM
  • It is in the documentation you linked but it is NOT on the page in the Azure portal where you verify the domain. The other instructions are there and this documentation page is not linked. This means that it's likely that people will get the file hosted at their root domain (this can be a hassle involving Corp IT and take a while) and then see the error, and then have to go through the Corp IT process again and hope they've fixed all the problems.
    Wednesday, October 9, 2019 3:44 PM
  • Hey Christi S,

    Ah I understand now, you would like it to be in the note in the azure portal. 

    I can engage with the azure product teams to look into this issue further. Thanks for letting us know your feedback!

    Friday, October 11, 2019 10:54 PM
  • I have done this but I still get an error.

    "... The server returned an unexpected content type header value. [whf+K]"

    My content header - as reported by chrome says 

    1. Cache-control:
    2. Connection:
    3. Content-Language:
    4. Content-Length:
    5. Content-Type:
    6. Date:
      Mon, 14 Oct 2019 19:48:23 GMT
    7. Server:
      Apache/2.4.39 (Amazon) mod_wsgi/3.5 Python/3.6.8
    8. Set-Cookie:
    9. Vary:
    10. x-content-type-options:
    11. X-Frame-Options:
    12. x-xss-protection:
      1; mode=block
    I am using django, any ideas?

    Monday, October 14, 2019 7:59 PM
  • Hello Mark, Please see the git issue :

    Monday, October 14, 2019 8:39 PM
  • I have tried the work around that I think is being suggested in that thread. It is a closed thread so not getting any response to further questions.

    1 - I created a new AAD user called Qwiqr.

    2 - And then I created a new app registration belonging to the new AAD user.

    3 - I tried to verify the domain, but I still get this error...

    "Verification of publisher domain failed. Error getting JSON file from ... The server returned an unexpected content type header value. [PMOxq]"

    The content type is "application/json", which I have seen is required elsewhere.

    HTTP/1.1 200 OK
    Cache-control: no-cache="set-cookie"
    Content-Language: en
    Content-Type: application/json
    Date: Tue, 15 Oct 2019 16:04:02 GMT
    Server: Apache/2.4.39 (Amazon) mod_wsgi/3.5 Python/3.6.8
    Set-Cookie: AWSELB=A9FDA12F0E5ABFD665AA7054525B2A118275F6A0D1F813AE4AF9762AAD4DE5A9B64B6626B247E5F93E6ABADADDD0A462AC6A62F598F8EF4CE5AE338FB5953711E64A2BA028;PATH=/;MAX-AGE=600
    Vary: Accept-Language,Cookie
    x-content-type-options: nosniff
    X-Frame-Options: SAMEORIGIN
    x-xss-protection: 1; mode=block
    Content-Length: 93
    Connection: keep-alive

    I have also tried giving the new user the Application Administrator" role, which didn't help either.

    My app uses django. This my first attempt to use Azure and I am not having much luck even getting started with this. Any suggestions please?

    Wednesday, October 16, 2019 7:11 PM