locked
Windows 10 Support? RRS feed

  • Question

  • User26582 posted

    I get the following error when I try to install/run a device in the Android Player in Windows 10 (build 10074).

    "Could not configure host-only network. Please reboot the computer and try again."

    I tried rebooting but no change. I confirmed the Windows firewall allows port 22468 internally externally.

    What else should I try/check?

    Thursday, May 7, 2015 11:05 AM

All replies

  • User26582 posted

    bump

    Friday, May 15, 2015 10:27 AM
  • User74873 posted

    Hi @robbschiefer, the Android Player needs VirtualBox to run, which unfortunately currently does not officially support Windows 10. You might have some luck if you try the newest VirtualBox 5.0 Beta from https://forums.virtualbox.org/viewtopic.php?f=15&t=67731, but I've not tested this yet.

    Friday, May 15, 2015 1:01 PM
  • User26582 posted

    Thanks for your help. I installed the beta but unfortunately it didn't help. Any other ideas?

    Saturday, May 16, 2015 2:08 AM
  • User74873 posted

    Unfortunately not, but looks like the VirtualBox team are aware of the issue so hopefully it will be fixed soon.

    You may want to follow this bug report: https://www.virtualbox.org/ticket/12182#comment:41 Or these threads: https://forums.virtualbox.org/viewtopic.php?f=15&t=67897 https://forums.virtualbox.org/viewtopic.php?f=15&t=66924 where other users have reported the issue.

    Sorry I couldn't be of more help, I'll keep an eye on it and update here once we have the Android Player confirmed working on Windows 10.

    Monday, May 18, 2015 5:21 PM
  • User26582 posted

    I have now tried the same setup on a Surface Pro 3 running Windows 8.1 and receive the following error:

    "Could not configure host-only network. Please reboot the computer and try again."

    Has anyone else seen this error?

    Saturday, May 30, 2015 2:50 AM
  • User50476 posted

    I'd expect that if you're running the VirtualBox 5.0 Beta 4, as the regression mentioned on this post also affects Win 8.1, so you'd need to use a stable version like 4.3.28. If you're not using the Beta then it might be a XAP problem, can you post any logs you have in C:\ProgramData\XamarinAndroidPlayer?

    Tuesday, June 2, 2015 4:38 PM
  • User26582 posted

    Sorry for the delayed response. I'm running a stable version of VirtualBox (4.3.18). There are no logs in C:\Program Files\Xamarin Android Player.

    Any other ideas?

    Monday, June 8, 2015 2:36 AM
  • User51368 posted

    @robbschiefer Please check in C:\ProgramData\XamarinAndroidPlayer\ for log files.

    Wednesday, June 24, 2015 8:15 AM
  • User26582 posted

    I found the logs. The latest update to the player must have fixed my issue because it works now.

    Thanks for your help!

    Wednesday, June 24, 2015 10:53 AM
  • User51368 posted

    That's great to hear :smile:

    Wednesday, June 24, 2015 11:10 AM
  • User105759 posted

    Bump, virtualbox worked on 4.3.23 which is a while ago according to https://forums.virtualbox.org/viewtopic.php?f=6&t=63923&sid=76c2133a8755ca9fe3e8b141aaf851c8&start=45. I tested with 4.3.28 which ran successfuly but XAP would stop the installation of new devices at the creating network interfaces part I believe. Does XAP try to create network interfaces? Because this is a known issue in 10130 which I'm currently stuck at.

    Sunday, June 28, 2015 2:23 PM
  • User51368 posted

    Yes, it does and the issue that XAP / VirtualBox has with Window 10 is that creating host only networks does not work.

    Monday, June 29, 2015 12:04 PM
  • User105759 posted

    I got a hold of 10147, 4.3.28 runs nicely but XAP does not. Confirmed that creation of bridged networking works in this build with workstation.

    Tuesday, June 30, 2015 4:20 PM
  • User51368 posted

    @MagnusBraathen.0786

    I am testing with build 10162 and can confirm that XAP fails to configure the host only adapter that it creates. If you manually configure one of the host only networks to the values that XAP expects then it does run.

    Adapter; IPv4 Address: 10.71.34.1 IPv4 Network Mask: 255.255.255.0

    DHCP Server; Enabled Server Address: 10.71.34.2 Server Mask: 255.255.255.0 Lower Address Bound: 10.71.34.101 Upper Address Bound: 10.71.34.199

    Could you try this and let me know how it goes? :smile:

    Friday, July 3, 2015 10:17 AM
  • User141502 posted

    Thank you, Mark. That did, in fact, work. For an explanation of how I did it, I ran VirtualBox as administrator, to configure the network as stated above. Then, I also had to run the Android Player as admin, so it could access the already configured network, and it runs smoothly now.

    Sunday, July 12, 2015 5:13 AM
  • User51368 posted

    @ChristianVollink That's good to hear. Did VirtualBox fail to configure the adapter without being run as admin? In my testing I found that the UI would let me configure it, it just required elevation to save it (which VirtualBox prompted for at the correct point). With it being set up this way, it meant i didn't have XAP as admin.

    Monday, July 13, 2015 8:05 AM
  • User141502 posted

    I found that for me, I could click to create a new adapter, but couldn't view or edit adapters without first running as an admin.

    Monday, July 13, 2015 11:27 AM
  • User125 posted

    I have Windows Build 10162 running. It is a fresh install. I have VB 5.0 downloaded and installed. I have just tried to run both XAP and VB as admin. I continue to get the XAP error about configuring a host only network connection. "Could not configure host-only network. Please reboot the computer and try again." Any ideas?

    Monday, July 13, 2015 6:30 PM
  • User656 posted

    After 3 failed installs, this is how I made it work with a fresh install on Windows 10! Step 1 If you previously installed Xamarin Player and already got the error message uninstall Xamarin Player and Virtual Box, then go to AppData/ and delete the complete XamarinPlayer directory.. At least make sure that under AppData there is NO longer any XamarinPlayer directory anymore available otherwise it won't work. Step 2 Download and install Xamarin Player But don't start it yet after installation Step 3 Download and install the latest Virtual Box version (5.x) just install it over the existing Virtual Box, it will clean and update automaticly the existing instance. Step 4 Open Virtual Box and go to File->Preferences->Networking and go to the Virtual Host Only Tab. Klik on edit for the one existing network adapter (the screwdriver) and make sure the it is set in the following way: (Thanks to @MagnusBraathen.0786) _Adapter; IPv4 Address: 10.71.34.1 IPv4 Network Mask: 255.255.255.0

    DHCP Server; Enabled Server Address: 10.71.34.2 Server Mask: 255.255.255.0 Lower Address Bound: 10.71.34.101 Upper Address Bound: 10.71.34.199_

    After this save settings and exit Virtual Box Step 5 Launch Xamarin Android Player and start installing virtual machines available for download. Now it will find the correctly configured host only network adapter.

    Hopefully this is a lifesaver for all people that have the same problem where they get the message that the host only network adapter could not be found or registered.

    Cheers Danny

    Monday, July 13, 2015 9:15 PM
  • User51368 posted

    @wallym

    As stated earlier in the thread, XAP does not currently work with Windows 10. You need to manually create / edit the adapter.

    Additionally it looks like there is an issue with VirtualBox 5, currently investigating.

    Tuesday, July 14, 2015 8:09 AM
  • User105759 posted

    @MarkSimpson Confirmed working after messing about for some hours. Edit: It booted once, after that I got OpenGL error. In annother thread the Xamarin employee said "You'll get that error if you try to change the network settings for the Player VM. You have to leave those alone." That's quite a paradox isn't it?

    Tuesday, July 14, 2015 1:54 PM
  • User96360 posted

    For me things started to work by

    1. installing VirtualBox 5.0 release
    2. going to Control Panel\Network and Internet\Network Connections and changing the VirtualBox NDIS 6.0 connection by enabling TCP/IP v4 (for some reason this was unchecked). I also configured it as described by Dannby above.
    Saturday, July 18, 2015 6:32 PM
  • User143146 posted

    Hi, I was able to install the devices after doing what @DannyPronk.2511 said and no more network error. Thanks!

    However, The XAP doesn't open any device, it takes a long time trying to acquire IP address, then it returns: "Failed to initialize device Nexus 4. Timed out waiting for IP address".

    Could it be related with the manual network configuration set or it's another issue? (I found a thread with this error but the answers aren't to windows 10)

    Does someone take the same problem and has solved it? Any clues?

    Windows 10: Build 10162 Preview Release (Build 0.4.3) VirtualBox 5.0.0.

    Thanks, AB

    Monday, July 20, 2015 1:07 AM
  • User143146 posted

    Hi guys, I got it working after uninstalling and reinstalling everything again. Now with VB 4.3.x. Just keeping the Adapter IP Address and DHCP mentioned by @DannyPronk.2511 . Time to go ahead. Thanks.

    Monday, July 20, 2015 5:08 PM
  • User138378 posted

    @DannyPronk.2511 i cant do Step 4 what can i do? i search everywhere but i cant find anything.

    Thursday, July 30, 2015 9:02 PM
  • User123442 posted

    @aberenguer Hi, Like you said, I have Uninstalled and reinstalled everything in my desktop. I tried to run my XAP with both VB 4.3.x and VB 5.0 (Windows host). But still I get this following error. Kindly help me out here!

    Friday, August 7, 2015 8:38 AM
  • User71908 posted

    Hi @SridharRamamoorthy, it's possible that the Virtualbox installations have not completed properly for some reason. Can you open a terminal/command prompt, run the "SET" command and confirm whether "VBOXMSIINSTALL_PATH" is set and valid?

    Friday, August 7, 2015 10:05 AM
  • User123442 posted

    Hi @LachlanMackenzie Is it safe to share my terminal results in public huh? Do you want me to hide/blur anything specific in my terminal results before I make a post here.

    Friday, August 7, 2015 10:18 AM
  • User71908 posted

    Hi @SridharRamamoorthy, apologies - I amended my post to just ask for confirmation that the parameter is set correctly rather than share the terminal results.

    Friday, August 7, 2015 10:28 AM
  • User123442 posted

    Hi @LachlanMackenzie Kindly don't mistake me, I was just clearly my doubt. Here you go! Hope it helps!

    Friday, August 7, 2015 10:45 AM
  • User71908 posted

    Hi @SridharRamamoorthy - it looks like the path hasn't been set by the installer for some reason. Has the machine been rebooted since the installation? This can sometimes resolve this issue - otherwise the path can be added and set manually through the advanced system properties window (further information can be found via https://msdn.microsoft.com/en-us/library/windows/desktop/ms682653%28v=vs.85%29.aspx). Typically the path should be something like "VBOXMSIINSTALL_PATH=C:\Program Files\Oracle\VirtualBox\" - but please confirm this on your own machine 1st before setting the value.

    Friday, August 7, 2015 11:02 AM
  • User123442 posted

    Hi @LachlanMackenzie Yeah I have rebooted my desktop a couple of times after installation. I can't understand what you said about the path and etc. Could you please explain it once again in a simpler way. Thanks!

    Friday, August 7, 2015 2:45 PM
  • User71908 posted

    Hi @SridharRamamoorthy, for the player to work it needs to know where VirtualBox is and it does this by looking for the environment variable that the VirtualBox installer should set when it's installed.

    In this case it looks like that environment variable hasn't been set for some reason and it needs to be set manually for the player to work.

    To set the variable you can either use the advanced system properties window (accessed via Windows control panel) or you can use the "SETX" command (https://technet.microsoft.com/en-us/library/cc755104.aspx). So for example the following will set a suitable user variable in my case:

    SETX VBOXMSIINSTALL_PATH "C:\Program Files\Oracle\VirtualBox\\"

    You will need to confirm what the path is to VirtualBox and that this is a suitable command for your particular circumstances.

    Friday, August 7, 2015 3:57 PM
  • User137962 posted

    i highly appreciate this thread..if it wasnt for the directions to get my emulator working in win10 development would be useless and by the time oracle or xamarin got their ps and qs straight school for me would have sucked..thank you to all!!!

    Wednesday, August 12, 2015 7:00 PM
  • User8903 posted

    @DannyPronk said: After 3 failed installs, this is how I made it work with a fresh install on Windows 10!

    For anyone else struggling with this, I can confirm that @DannyPronk's method worked perfectly.

    Monday, August 15, 2016 11:37 PM