locked
Windows Phone SDK 7.1 RC RRS feed

  • Question

  • Hi,

    I was in the process of updating the developer tools to RC. So downloaded the RC version using the link provided on the home page. Launched the installer and I got the screen asking whether to Repair/Reinstall or Unistall WP SDK 7.1 RC. I wasn't expecting this. I checked the Add/Remove programs. To my surprise it showed WP SDK 7.1 (RC) - ENU. Installed on 08/07/2011, Version 10.1.40219.

    Am I running the most recent version of the developer tools? I don't recall installing RC version. The one I installed on the 08/07 was the Beta 2 Refresh of the OS and corresponding developer tools I got from the connect web site. I am so confused. Could someone running the RC version of the tools please confirm the version no?

    thanks,
    Gilles
    Saturday, September 10, 2011 5:51 PM

Answers

  • Hi Gilles,

    I installed RC on the 1st and it shows the same version as the one you listed.
    Also, the RC tools were release on August 22nd.
    Sunday, September 11, 2011 5:00 AM
  • Launched the installer and I got the screen asking whether to Repair/Reinstall or Unistall WP SDK 7.1 RC.


    If setup launched in repair mode the first time you ran it, then I think you may have had a previous beta installed and then ran the installer for the RC without first uninstalling the beta.  If so, you likely have a mixed and matched set of beta and RC components.  I'd suggest fully uninstalling the version of the Windows Phone SDK 7.1 that you have installed, then re-install the Windows Phone SDK 7.1 RC just to be sure you have the right versions of everything.


    Version 10.1.40219.


    All versions of the Windows Phone SDK 7.1 have these 3 version numbers.  To tell for sure which version you have, you need to know the 4th part of the version number.  You can check the version of the file at %programfiles%\Microsoft Visual Studio 10.0\Common7\IDE\vpdexpress.exe (or %programfiles(x86)% on a 64-bit OS) to tell what the 4th part of the version number is.  This file should have version number 10.1.10419.166 for the RC.

    Thanks!
    Sunday, September 11, 2011 5:03 PM

All replies

  • Hi Gilles,

    I installed RC on the 1st and it shows the same version as the one you listed.
    Also, the RC tools were release on August 22nd.
    Sunday, September 11, 2011 5:00 AM
  • Thanks for confirming the version no. Cellinova Inc. That's why I am so confused. The tools were made available on 08/22 and I installed it on 08/07.
    Sunday, September 11, 2011 2:52 PM
  • Launched the installer and I got the screen asking whether to Repair/Reinstall or Unistall WP SDK 7.1 RC.


    If setup launched in repair mode the first time you ran it, then I think you may have had a previous beta installed and then ran the installer for the RC without first uninstalling the beta.  If so, you likely have a mixed and matched set of beta and RC components.  I'd suggest fully uninstalling the version of the Windows Phone SDK 7.1 that you have installed, then re-install the Windows Phone SDK 7.1 RC just to be sure you have the right versions of everything.


    Version 10.1.40219.


    All versions of the Windows Phone SDK 7.1 have these 3 version numbers.  To tell for sure which version you have, you need to know the 4th part of the version number.  You can check the version of the file at %programfiles%\Microsoft Visual Studio 10.0\Common7\IDE\vpdexpress.exe (or %programfiles(x86)% on a 64-bit OS) to tell what the 4th part of the version number is.  This file should have version number 10.1.10419.166 for the RC.

    Thanks!
    Sunday, September 11, 2011 5:03 PM
  • Sunday, September 11, 2011 5:24 PM
  • If setup launched in repair mode the first time you ran it, then I think you may have had a previous beta installed and then ran the installer for the RC without first uninstalling the beta.  If so, you likely have a mixed and matched set of beta and RC components.


    Strange, Ideally if you had Beta installed while installing RC you should hit installation blocker asking you to uninstall Beta before continuing with the installation.
    Can you provide more details like what is the version of vpdexpress.exe as pointed by Aaron.
    Also can you please run the following log collection tool and share the 'vslogs.cab' file it generates in %temp%.

    Thanks,
    Kedar
    Monday, September 12, 2011 12:45 PM
  • Thanks a lot for the replies. Really appreciate it.

    Aaron,

    The version of VPDExpress.exe is 10.1.40219.145. So that shows I am not running the actual RC build.


    Kedar,

    I ran the tool you provided in the link. How could I share that with you?

    thanks.
    Wednesday, September 14, 2011 10:53 PM
  • You can share it on the sky drive...
    Thursday, September 15, 2011 1:10 PM
  • Kedar,

    Sorry. I was out of the country. I know its kind of late. Here is the link if you would like to take a look.

    cab file

    thanks,
    Gilles
    Saturday, October 1, 2011 2:35 PM
  • Hi Giles,

    Thats really surpising, You seems to get hold of unreleased version of RC. If I remember correctly Released Beta2 Refresh was version 10.1.40219.115 and Released RC is version 10.1.40219.166. There is no other release between these two. Somehow you are able to manage to get 10.1.40219.145 build and hence issue is appearing.

    I can see that you have installed Last bits through DVD Install by running setup.exe directly "E:\WP7\OS\v7.1 - Mango Refresh\WPSDK Beta 2 Refresh\WPSDK71_Beta2Refresh\dvd\setup.exe". If you can remember from where did you get hold of this DVD, We can figure out source of problem.
    Monday, October 3, 2011 3:49 AM
  • Hi SGupta,

    I downloaded the Beta2 refresh from the Connect website on 08/06/2011. The connect site was not available for sometime between 08/05 and 08/06 and there is a thread indicating about this. Pls refer the thread Mango Build not available. So I got the refresh build from connect on 08/06 and installed it on 08/07. Please note that I went from NoDo to Mango Beta2 refresh. Later I downloaded the RC build using the link provided on the Developer Hub home page. I believe that was on 08/27 and that's where I ran into the conflict. I still have all the zipped files that I got from the connect site. I could upload everything to the skydrive, if you would like to look further.

    P.S. Based on the recommendation from the other posters on this thread, I uninstalled the Refresh2 build (.145) and installed the latest RTM build.

    thanks,
    Gilles
    Monday, October 3, 2011 11:53 AM