none
How to avoid writing to CF during reboot RRS feed

  • Question

  • Hello!

    I have a problem with my Windows CE 6.0 device. I use device with compact flash and it's undesirable to write to CF often.
    My OS design is compiled with hive-based registry, so at least at each reboot WinCE writes some files to CF
    (as user.hv, system.hv, bootlog.txt, bootlog.prv etc.).

    I don't know why i can't switch to ram-based registry in VS.
    What can i do to avoid writing to CF during reboot?

    Thanx!


    • Edited by Olaiya Friday, January 22, 2016 7:40 AM
    Friday, January 22, 2016 7:38 AM

Answers

  • Check your BSP.bat file (in the root of your BSP) and make sure PRJ_ENABLE_FSREGHIVE (or something similar) or SYSGEN_FSREGHIVE is not set.

    Open a build command window and type "set", then show the output here so we can see what is set.

    Also check your flatreldir for the file sysgensettings.out and show its contents here.

    Something inside your BSP is setting the variable for hive, you need to find out what and disable it.

    What BSP are you using?


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.

    • Marked as answer by Olaiya Monday, January 25, 2016 9:52 AM
    Monday, January 25, 2016 8:10 AM
    Moderator

All replies

  • I don't know why i can't switch to ram-based registry in VS.


    Why can't you switch to RAM based registry? With hive based registry, you will ALWAYS have some writes to CF at boot.

    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.

    Monday, January 25, 2016 12:15 AM
    Moderator
  • VS doesn't allow. I can't insert any picture before my account will be verified, but there is "green square" at hive-based registry in Catalog Items View and i can't switch to ram-based.
    Monday, January 25, 2016 7:39 AM
  • Check your BSP.bat file (in the root of your BSP) and make sure PRJ_ENABLE_FSREGHIVE (or something similar) or SYSGEN_FSREGHIVE is not set.

    Open a build command window and type "set", then show the output here so we can see what is set.

    Also check your flatreldir for the file sysgensettings.out and show its contents here.

    Something inside your BSP is setting the variable for hive, you need to find out what and disable it.

    What BSP are you using?


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.

    • Marked as answer by Olaiya Monday, January 25, 2016 9:52 AM
    Monday, January 25, 2016 8:10 AM
    Moderator
  • Thank you, both these variables were set. I have switched to ram-based registry))

    It's BSP by Advantech for Advantech PCM3353 device.


    • Edited by Olaiya Monday, January 25, 2016 9:22 AM
    Monday, January 25, 2016 9:21 AM
  • There is only one problem)))

    Is it possible to not create "bootlog.txt", "boot.prv"?

    Tuesday, January 26, 2016 8:26 AM