none
Debuging over LAN RRS feed

  • Question

  • Hi all,

    I am having a problem with DiskPrep tool.

    I want to prepare USB key drive to send bootme messages to be able to debug from VS2005 than.

    But when I insert USB and try to boot my PC freezes. If I load an image for WinCE it boots OK.

    I also tried to copy files from C:\WINCE600\PLATFORM\CEPC\SRC\BOOTLOADER\DOS\BOOTDISK but it didn't help either.

    What am I missing here?

    Monday, October 18, 2010 1:59 PM

All replies

  • Bojan:

    You didn't tell us what you did or what you see.  "PC freezes" means nothing or a lot, what actually happens would be much more important.  "If I load an image..." - what does that mean?

    Does your device boot from USB?  I mean is that an option and is it enabled?  Is anything coming out on the display?  The debug serial port?


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Tuesday, October 19, 2010 1:23 AM
    Moderator
  • Well if I make an image in Platform Builder and use DiskPrep tool than I can boot to WinCE from CF card.

    If I use DiskPrep to prepare CF for booting to eboot, than I am left with WindowsEmbedded CE 6.0 logo and nothing else (numlock key on keyboard is not responding).

    Tuesday, October 19, 2010 8:55 AM
  • Well, I wouldn't expect numlock to necessarily respond since eboot doesn't really do much except read key presses.

    Since eboot is going to try to download via Ethernet, do you have Ethernet connected?  Is your computer on the same subnet?  Do you start the download in Platform Builder.

    The more information you give, the faster this will go.

    Again, serial debug output?


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Tuesday, October 19, 2010 11:52 AM
    Moderator
  • Bruce,

    sorry for my late answers. Yes the ethernet is connected and both computers are on same subnet. In Platform Builder I do not start download. I added new device in Target Device Connectivity Options (typed the name and choose the SDK), and than I click on Download - choose Ethernet - press Settings but the devices name doesn't show up.

     I don't have serial debug connected jet - waiting for null cable to come.

    With my USB key is strange... if I use HP tool to make it bootable it boots into dos from Win98 (but eboot doesn't work because it wants another hymem.sys), but if I use DiskPrep (using an image - nk.bin) I just got blank screen. So I guess the board can boot from USB.

    Friday, October 22, 2010 10:42 AM
  • After pressing settings, you do need to reboot your device so that it sends out BOOTME messages for it to show up in the list.

    In a previous post you said that the Windows CE logo is shown, in this last post you say blank screen.  Which do you actually see?


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Friday, October 22, 2010 11:18 AM
    Moderator
  • Well with USB key I got black screen, with CF I get WinCE logo.

    I tried to reboot after pressing the settings, but it don't work either way.

    Friday, October 22, 2010 12:24 PM
  • What is the size of your USB disk and CF card?
    Do you select FAT or FAT32 in Diskprep?
    Suppouse the USB Disk with large size (>2GB), if you select FAT to prepare the disk, the BIOSLOADER and Bootsector may not work.
    Sunday, October 24, 2010 5:27 PM
  • USB key is 256MB and it is FAT formated, CF is 4GB and it is exFAT.
    Tuesday, October 26, 2010 10:54 AM
  • I have finally got the null modem serial cable, but during the boot I do not see any output from COM1 with settings: 1 stop bit, 8 data bits, no parity and Baud rate: 38400 or 115200. Anyone can give me some directions?
    Wednesday, October 27, 2010 8:56 AM