none
Microsoft.SQLSERVER.MOBILE.OLEDB.3.0 on Windows 7 ? RRS feed

  • Question

  • Hi all,

    i use VS2005 and VS2010 with sql server as my main dev tools.

    Recently i had to work on an old application with Delphi 6.0. (No choice, as porting that would take 6 months and at this point nobody has the time).

    did some Mobile 6.1 development work, works fine on the VS side, and works fine on my development machine, even with delphi connecting to the sdf file through this provider: Microsoft.SQLSERVER.MOBILE.OLEDB.3.0

     

    The problem is that when i try to connect to an sdf file using the following provider Microsoft.SQLSERVER.MOBILE.OLEDB.3.0  in Windows 7 - 64bit, i get the following error: Unspecified Error

    I checked if the oledb 3.0 is registered, and it is. i also found entries to newer versions in the registry.

    i've re-installed the 3.0 oledb provider, and installed the compact sql, with no luck.

    i've spent 3 days looking online for a solution, nobody knows a way around this.

     

    Monday, September 12, 2011 3:39 PM

All replies