locked
IIS 7 Windows 2008, Localhost work but not local ip or external ip RRS feed

  • Question

  • User-1611504658 posted

    Hi all,

     we have iis server with 2 web site. default web site on port 80 work with localhost or public ip, and local ip -> http://localhost http://192.168.5.1 and http://externalip

     

    we have another web site on port 5000. it work with htt://localhost:5000 but not with local ip or external ip.

     very long time that i search without results.

     

    if anybody can help me.

     

    Tks advance

    Tuesday, January 24, 2012 9:29 AM

Answers

  • User-1611504658 posted

     I found !!!

     

    it's local policies on windows 2008 r2. it disable all incoming connexion except *:80 it's for this.

     

    Now all work.

     

    Tks for your help Fab and Martin

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, January 31, 2012 3:14 AM

All replies

  • User690216013 posted
    Check the settings of that site (such as binding) to make sure you don't bind it to localhost:5000 only. You need to bind it to [all unassigned]:5000.
    Tuesday, January 24, 2012 10:57 PM
  • User-1611504658 posted

     Tks lex for your reply,

     

    in fact i check this before and it's *:5000 but same things.

    Wednesday, January 25, 2012 7:38 AM
  • User-1499466209 posted

    Hi,

    when you try to browse 'http://192.168.5.1:5000'is it from the webserver (where the site is hosted) or from a client PC?

    If it's from a client PC, are you sure nothing (like a firewall...) is between the client PC and the server and block the connections on the TCP 5000 port?

    If it's from the webserver do you have something like RequestFiltering module or URLScan installed?

    Wednesday, January 25, 2012 7:45 AM
  • User-1611504658 posted

     Hi tks for your reply,

     

    it's from server, and its' defaut installation of 2008, with nothing except IIS. where i can found requestfiltering and urlscan ?

    Wednesday, January 25, 2012 9:59 AM
  • User-1611504658 posted

     in fact i have this 2 installed module. can you help me to configure them ?please

     

    tks advance for your help

    Wednesday, January 25, 2012 10:02 AM
  • User-1499466209 posted

    http://www.iis.net/ConfigReference/system.webServer/security/requestFiltering

    but if you didn't configure it, it's probably not the cause of your problem...

    Wednesday, January 25, 2012 10:06 AM
  • User-1499466209 posted

     I should asked this one first : could you give us the full error code (status code AND sub status) from your IIS log file when you try to browse the website on the TCP 5000 port?

    Wednesday, January 25, 2012 10:10 AM
  • User-1611504658 posted

     It's like server don't found ip. the defaut web site works but not others.time out in Internet explorer

     

    On log only works connection are visible not other.

    Wednesday, January 25, 2012 10:46 AM
  • User-1499466209 posted

     Ok, let's do it from the beginning:

    can you run these tests: open a MSDOS command, and run the command 'telnet IP_ADRESS 5000' and see if it works (if it opens the connection)

    Do it from the server and from a client PC too

    Do it replacing IP_ADDRESS by private IP, and then replacing IP_ADDRESS by public IP from client PC, and just the private IP address from the server.

     

    By the way, if you don't see any entry in the IIS log file , it seems that your request never arrives to the server. But what I can't understand it's why it wouldn't arrives when you try to browse the site from the server...

    Wednesday, January 25, 2012 11:22 AM
  • User-1499466209 posted

    Another question : if we don't have anything in the server logs, we will try to know what the client can say... Disable HTTP friendly errors in IE, and give the full error message and error code.

    Wednesday, January 25, 2012 11:24 AM
  • User-1611504658 posted

     Merci Fab de votre aide.

     

    I try telnet, with localhost 5000 it's work (on the server) but with ip 192.168.5.1 don't :'(

     i have disable http friendly and message is "time out".

     

    :( 

    Thursday, January 26, 2012 3:30 AM
  • User-1672167363 posted

    Hi,

    A small interrupt for this thread "Localhost" works Yes. But not local IP Address The External is DNS"

    The tools you need:

    Command Prompt >netstat -ano

    >nslookup

    >ping 

    End of interrupt.

    Just a suggestion,

    Regards,

    Martin

     

     

    Thursday, January 26, 2012 4:04 AM
  • User-1499466209 posted

    I try telnet, with localhost 5000 it's work (on the server) but with ip 192.168.5.1 don't :'(
    From the server (the failed test with the private IP)?? It SHOULD work from the server on its own IP, exactly like with localhost... Or maybe there is a network configuration problem...

    Just check a couple of things :

    - your IP address is 192.168.5.1 on the sever

    - you website (the one on the TCP 5000 port) is configured to use 192.168.5.1

    To understand ourselves, can you fill this form:

    on the server : telnet localhost 5000 > OK / <strike>NOK</strike>

    on the server : telnet 192.168.5.1 5000 > OK / NOK 

    on the server : telnet PUBLIC_IP 5000 > OK / NOK 

    on a PC client : telnet PUBLIC_IP 5000 > OK / NOK

    on a PC client : telnet 192.168.5.1 5000 > OK / NOK (do it only if the PC client is able to contact the 192.168.5.xxx subnet)

     

    Keep the faith! We will find the problem... ;)

     

     

    Thursday, January 26, 2012 4:20 AM
  • User-1611504658 posted

     it's simple,

     

    with IIS default website 

    http://locahost:80 OK

    http://internalIP:80 ok

    Http://ExternalIP:80 OK

     

    on the server : telnet localhost 5000 > OK

    on the server : telnet 192.168.5.1 5000 > NOK

    on the server : telnet PUBLIC_IP 5000 > NOK

    on a PC client : telnet PUBLIC_IP 5000 > NOK

    on a PC client : telnet 192.168.5.1 5000 > NOK (do it only if the PC client is able to contact the 192.168.5.xxx subnet)

     

    on the server : telnet localhost 80 > OK

    on the server : telnet 192.168.5.1 80 > OK

    on the server : telnet PUBLIC_IP 80 > OK

    on a PC client : telnet PUBLIC_IP 80 > OK

    on a PC client : telnet 192.168.5.1 80 > OK (do it only if the PC client is able to contact the 192.168.5.xxx subnet)

     

    MY network config

     

    1 network card with external ip directly (no router and firewall windows allow all)

    1 newtork card with ip 192.168.5.1 (openvpn server) works good

    1 network card with 192.168.6.1 no use

     

     

    tks advance

     

    Thursday, January 26, 2012 4:28 AM
  • User-1499466209 posted

    Not that simple, otherwise it would be already solved... ;)

    Now I need to think about it... I will come back to you.

    Thursday, January 26, 2012 4:39 AM
  • User-1611504658 posted

     Ok,

     

    tks so much for your help

    Thursday, January 26, 2012 10:19 AM
  • User-1611504658 posted

     HI,

     

    so nobody have an idea where my prob come from ?

     

    tks

    Monday, January 30, 2012 6:22 AM
  • User-1672167363 posted

    Hi,

    At first glance a Router and Domain is missing. What is with the OpenVPN server ? Static IP Addresses ?

    1 NIC external ip directly (no router) 1 NIC IP 192.168.5.1

     (openvpn server) works good 1 NIC IP 192.168.6.1 no use ?

    Do you own a registered Domain ?

    HTH

    Regards, 

    Martin

     

    Monday, January 30, 2012 8:32 AM
  • User-1611504658 posted

     Tks hcampers for your reply

     

    router is missing because it's dedicated server on 1and1 provider, and we only have accès to external ip configured on network card of serveur. open vpn use external ip to allow open vpn client.

     

    there is no domain juste dns name redireted to external ip and so to server.

    Monday, January 30, 2012 10:57 AM
  • User-1672167363 posted

    Hi,

    In the IIS Forums a simple diagram: might be  | Local  Machine | NIC | Machine| VPN  { Cloud  } --> Hosting Service.  

    The way to communicate Networks and the connections is Topology: http://en.wikipedia.org/wiki/Computer_network_diagram 

    I always start with paper and pencil. The alternatives http://en.wikipedia.org/wiki/Comparison_of_network_diagram_software .

    You can use Grapics and an Editor to Diagram using symbols to represent what is connected.

    where every thing is located http://en.wikipedia.org/wiki/OSI_model by the Layers for the NIC Hosting at

     1 & 1 Provider If you mean Yahoo Search http://answers.yahoo.com/question/index?qid=20110725121707AAdGYrK 

    HTH

    Martin

     

     

     

     

     

    Monday, January 30, 2012 11:19 AM
  • User-1611504658 posted

    Ok i will explain

    My  web server | NIC 1 ip 82.164.x.x / NIC 2 192.168.5.1 | Internet

    From server http://localhost default web site of IIS

    From server http://localhost:5000 my default website

    From server http://82.164.x.x IIS web site

    From server http://82.164.x.x:50000 Not work

    my binding is *:5000

    Monday, January 30, 2012 1:38 PM
  • User-1611504658 posted
    and i add that is ASP.net application
    Monday, January 30, 2012 2:36 PM
  • User-1672167363 posted

    Hi,

    Looks better :D.

    I do not speak French: Thank you very Much.

    merci beaucoup at this point  Fab can help

    Regards, 

    Martin

     

    Monday, January 30, 2012 2:46 PM
  • User-1611504658 posted

     I found !!!

     

    it's local policies on windows 2008 r2. it disable all incoming connexion except *:80 it's for this.

     

    Now all work.

     

    Tks for your help Fab and Martin

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, January 31, 2012 3:14 AM
  • User-1499466209 posted

    I do not speak French: Thank you very Much.

    merci beaucoup at this point  Fab can help

    Yep, but for everyones sake, I think we should exclusively use english, event if sometimes, something could be lost in translation... :)

    I found !!!

     it's local policies on windows 2008 r2. it disable all incoming connexion except *:80 it's for this.

    Great! I add GPO verification in my troubleshooting scenario... We should have think about it earlier...

    Tuesday, January 31, 2012 3:27 AM
  • User-1672167363 posted

    Hi Fab,

    True the translation and language are one of the problems :) 

    The process of translation the meanings of words can change True. 

    Logically speaking for computers translation maybe easier to understand.;-].

    From my understanding from Engineering True is always (True = 1);

    From my understanding of Networks the language words and terms are not so easy to translate.

    The OSI Model and Networks understanding  is the  Layers make this easier to translate the terms and words.

     I agree we should exclusively use english in the possible  event.something might be lost in translation (True).. :)

    The Network and the Layer and the understanding are like an Onion.

    From my education and by design to make things simple to understand the Onion makes the language easier.

    Now on a lighter side of things: How my teacher presented the OSI Model and Security.

    Note 1: Shrek 1 the movie OSI Model and Security.

     

    What is the relation between security and Shrek?

    Shrek is an Ogre, Ogres are like onions, onions have layers thus Shrek has layers.

    Security should also have layers and thus security should be like Shrek

    (in the sense that it has layers and not that it is comical and certainly not that it smells).

    I am glad that it was local policies and Windows 2008 R2

     GPO ( Group Policy Objects)  that in the Tier connexion  is now  usable at port 80.

    Trouble Shooting is not easy to isolate test and  verification and scenarios can be complex pinpointing the root cause of the

    problems and issues. The methods and approach can lead to "I Found !!!" very happy this is now True.

    Thanks for helping,

    Regards,

    Martin

     

     

    Tuesday, January 31, 2012 5:19 AM