locked
WACK fails test "Hangs and crashes" test for every project RRS feed

  • Question

  • Hi,

    Its my first Windows Store App (I develop for Windows Phone 8). Problem is that Windows App Cert Kit fails tests for "Crashes and hangs" for my project. I have also tried to run WACK for Windows 8 samples, there also it fails. Is there something wrong with my setup? I am trying for 2 days, searching forums, reading docs... nothing helped. Please help me.

    WACK version 3.1, running on Windows 8 Pro N (x64), Visual Studio 2012 Ultimate.

    Thanks

    Sunday, October 20, 2013 4:49 PM

All replies

  • It is possible the issue is with the app you are testing.  I would also make sure there is nothing running at the same time as test kit is.  
    Sunday, October 20, 2013 5:04 PM
  • I found issues with hangs/crashes in my apps.

    I found most of my problems with crashes/hangs were due to async functions being waited for.

    Take care with async functions and make sure you look for any exceptions on unexpected returns due to a problem.


    n.Wright


    Sunday, October 20, 2013 8:19 PM
  • Hi nigelwright7557,

    To make sure that it is not the async functions which are causing the trouble, I created a blank project and did not change anything. Then I ran WACK 3.1 for crashes and hangs test, but it also failed.

    I have also tried running the same test on one of the Windows 8 samples ("Sharing content as source" sample to be more specific) but the results are same, it also failed.

    Can Visual Studio Update 3 solve my problem? because I don't think I installed it yet (I am running original Visual Studio with no upgrades).

    Monday, October 21, 2013 10:48 AM
  • Hi Ken,

    What kind of programs should I close during the testing? I only have Apache server running that should not affect the testing. But to make sure it doesn't affect, I have shutdown all the unnecessary services (VMware services and Apache Services), but still it fails.

    I have tried test on 3 projects (my own, blank app and Windows 8 sample) but all 3 are failing. That means the issue is either with my installation (I have not updated VS12 ultimate to update 3) or with my PC. Any help would be appreciated.

    Monday, October 21, 2013 10:58 AM