locked
Internet Explorer 11 not playing audio file in EW4 RRS feed

  • Question

  • Are there any known issues with Internet Explorer 11 as the Preview Browser for EW4? I can no longer play audio files in a <audio> tag. My code is shown below:

    <html>
    <head>
    </head>
    <body>
     
       <audio controls = "controls" ><source src="chapter1readweb.mp3"  type="audio/mp3">
           <p>Your user agent does not support the HTML5 Audio element</p>
       </audio>
        
    </body>
    </html>

    I can right click on the audio controls and select play and mute. But I can no longer simply click the play button or move the time slider or the volume slider. I use to be able to do this just days ago. Was there another update to IE that disables this feature? Do I need to reinstall EW4? The audio controls do work as expected in Foxfire and in Chrome, but not in IE11 anymore. Any help would be appreciated. Thanks.

    Tuesday, December 16, 2014 3:06 AM

Answers

  • I found the problem. I had to add in the attribute   onclick  in the <audio> tag. Usually one would write onclick="somefunction()". But I do not have to include the ="somefunction()"; I only use the onclick keyword. Then it works in IE11, Foxfire, and Chrome. Don't ask my why. Thanks.

    • Marked as answer by Mikeatmsdn Tuesday, December 16, 2014 4:04 PM
    Tuesday, December 16, 2014 4:04 PM

All replies

  • What happens in IE11 has nothing to do with EW. It has everything to do with IE11. There is nothing special about Preview in Browser from EW—EW simply launches IE as a process, passing the currently focused file as an argument. At that point its involvement ends completely, and IE parses and renders the markup in the file according to its rendering engine.

    Given IE's checkered, maddening history, there is probably some little oddity of syntax which keeps some resource or other from loading, or an obscure parameter that needs to be enabled, or something equally trivial but frustrating until it is found and documented so it can be easily googled. Whatever it might be, it is not an EW issue, and you would probably be better off asking this question in a forum dedicated to IE itself.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Tuesday, December 16, 2014 5:18 AM
  • No. There is no connection to using a browser as a preview browser in EW and any change in its behavior. Previewing in a browser via EW simply opens that browser and displays your page.

    If the code works in IE11, it will work previewing via IE11.

    When you say "no longer", what do you mean?  Did it play in IE11 before?

    I will say that I think your type is wrong.  For mp3, it's type="audio/mpeg".

    That doesn't change if it will work in IE11 or not - it works both ways for me.

    (Are you getting a blocked content warning that you are ignoring?  Local files are treated with higher security/more concern than files on the web, and IE11 warns about blocking the audio content at first, and you must allow it.)

     
    • Edited by KathyW2 Tuesday, December 16, 2014 6:22 AM
    Tuesday, December 16, 2014 5:32 AM
  • Scott, there is nothing checkered about IE11 and the audio tag. See my post: it works just fine, as written by the OP, unless the OP didn't see the "blocked content" notice (and unblocked it) from the higher security IE puts around local files on your PC.
    Tuesday, December 16, 2014 7:39 AM
  • I found the problem. I had to add in the attribute   onclick  in the <audio> tag. Usually one would write onclick="somefunction()". But I do not have to include the ="somefunction()"; I only use the onclick keyword. Then it works in IE11, Foxfire, and Chrome. Don't ask my why. Thanks.

    • Marked as answer by Mikeatmsdn Tuesday, December 16, 2014 4:04 PM
    Tuesday, December 16, 2014 4:04 PM
  • I did not have to add an onclick function to make IE11 work. Your code, as written, worked fine.
    • Edited by KathyW2 Wednesday, December 17, 2014 1:51 AM
    Tuesday, December 16, 2014 6:24 PM