locked
How to solve dependancy error on UWP xamarin Based application RRS feed

  • Question

  • I make new xamarin based app it build and works proper but when I try to build it works proper but when I try to publish it in Windows store i get this error on my x86 package but x64 package works proper.

    I mention error here:

    The declared package dependency does not exist. Dependency: Microsoft.NET.Native.Framework.Debug.2.0. Minimum version: 2.0.25709.0. Please upload the .msixupload or .appxupload file generated by Visual Studio for the Store.

    There is one other issue I facing one issue and that is there is no release option for x86 architecture and that's why I am using Ad-Hoc(x86).

    Can anyone have idea about this? Please guide.


    Monday, February 18, 2019 5:12 AM

All replies

  • Hi Dep Soni,

    >There is one other issue I facing one issue and that is there is no release option for x86 architecture and that's why I am using Ad-Hoc(x86).

    What did you choose when you create the xamarin  app? Could you package a sample to test? If the sample could be packaged successfully and pass the WACK test, could you open up the .csproj file in the project solution folder and compare it with the sample app? 

    Best regards

    Daisy  Tian


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, February 18, 2019 8:56 AM
    Moderator