locked
how to hide columns in edit form.aspx in moss 2007 RRS feed

  • Question

  • hi Friends,

    i have created a list in moss 2007 which have 5 columns i want to hide 2 columns when some one edit

    i have hide successfully these 2 columns(in newForm.aspx) from designer  when someone do newitem but in edit although i copy same code but  it is appearing

    should i need to do some different thing for editForm.aspx i changed  ids of control now what is need to be done .

     

    Please help :)


    sudhanshu sharma
    Wednesday, August 24, 2011 6:59 AM

Answers

  • In SP Designer, Go to Edit form's design view and remove the fields which need to hide.
    Wednesday, August 24, 2011 11:55 AM

All replies

  • In SP Designer, Go to Edit form's design view and remove the fields which need to hide.
    Wednesday, August 24, 2011 11:55 AM
  • hi Arun,

    In SP Designer when i work in design mode these columns should be shown bydefault it does not show ,only 3 columns appear  i need to do custom form operation ...as i did with new form....but nothing is appearing for edit form

    what to do?


    sudhanshu sharma
    Wednesday, August 24, 2011 12:37 PM
  • Go to Design mode and remove the default form displayed..

    and Go to insert --> Sharepoint controls --> select the list

    a pop-up windows appear, select Edit form in that windows and click ok

    Once it is done, you will get a actual form in the Design View.

    Wednesday, August 24, 2011 2:37 PM
  • hi Arun ,

    I did the same thing already . problem is this process worked for NewForm .aspx but not for EditForm.aspx..it was strange for me .

     

    by the way thanks:)


    sudhanshu sharma
    Thursday, August 25, 2011 4:16 AM
  • Another option so that you don't have to modify the default pages is to use jQuery to hide those fields.  This allows you to hide the fields without unghosting your page. 

     

    To put the default page in edit view you can append "&ToolPaneView=2" in the url for the page.  

     

    Good luck,
    Mark 


    The SharePoint Hillbilly
    Fewer Big Words... More Pretty Pictures... http://www.SharePointHillbilly.com
    Thursday, August 25, 2011 12:49 PM
  • Hi sudhanshu,

     

    Did all the user still see the 2 columns in EditForm.aspx which have been removed?

    You need to check and make sure the modified EditForm.aspx page were “Check In” in the Designer.

     

    Thanks


    Regards, Daniel
    Wednesday, August 31, 2011 2:05 AM
    Moderator