locked
Lightswitch, Ria Services, and the Distributed Transaction Coordinator??? RRS feed

  • Question

  • I've set up a lightswitch project which uses Ria Services to access data from an external database.  The application is setup as a three tier web deployment app.  When I attempt to open a search screen, I receieve the following error:

    [Microsoft.LightSwitch.DataService][Application:Error][LightSwitchApplication.OnlineJobAppDomainServiceData:Applicants_All] An exception has occurred: Microsoft.LightSwitch.DataServiceOperationException: The underlying provider failed on Open. ---> System.Data.EntityException: The underlying provider failed on Open. ---> System.Transactions.TransactionManagerCommunicationException: Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administrative tool. ---> System.Runtime.InteropServices.COMException: The transaction manager has disabled its support for remote/network transactions.

    My remote sql server does not have "allow remote connections" turned on in the MSDTC settings.  Is there a way to prevent the application from using the Distributed Transaction Coordinator in this scenario?

     

    Wednesday, August 17, 2011 3:57 PM

Answers

  • I have resolved this issue by disabling the use of MSDTC.  To disable, I set "Enlist=false;" in my connection string to the database.
    Monday, October 31, 2011 7:43 PM

All replies

  • When this happened to me I had connection pooling turned off in my connection string (which somehow triggered msdtc to be requred)

    • Proposed as answer by ADefwebserver Saturday, August 20, 2011 4:34 AM
    Saturday, August 20, 2011 3:10 AM
  • Have you found a solution to this issue?  I have getting the same error but have not seen any solution.  In my case, I am using SQL Azure and therefore cannot simply allow remote connections in MSDTC.  I do not have pooling explicitly turned off in my connection string.

    I should not that I am using a Domain service that connects to the Entity Framework.

    Any help explaining how to explicitly disable the use of MSDTC either in Lightswitch or in the Domain service would be very helpful.

    Wednesday, October 26, 2011 7:30 PM
  • Does this post help, despite the fact that it's talking about MySQL?

    Yann - LightSwitch Central

    (plus ça change, plus c'est la même chose!)

    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, remember to "Mark as Answer".

    This will help people find the answers that they're looking for more quickly.

    Thursday, October 27, 2011 12:41 AM
    Moderator
  • I have resolved this issue by disabling the use of MSDTC.  To disable, I set "Enlist=false;" in my connection string to the database.
    Monday, October 31, 2011 7:43 PM
  • Your solution fixed my problem.  Thanks!  +1
    Wednesday, August 27, 2014 6:50 PM