RDP connectivity problem RRS feed

  • Question

  • Hi All,

    I've 4 different virtual machines and suddenly I've lost connectivity to one of them. I've read support forum

    and have checked endpoint ports, recreated RDP Port again ,resizing VM ,Firewall of my computer ,restarting that 

    VM ,but I always get 

    [Window Title]
    Remote Desktop Connection

    Remote Desktop can’t connect to the remote computer for one of these reasons:

    1) Remote access to the server is not enabled
    2) The remote computer is turned off
    3) The remote computer is not available on the network

    Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

    [OK] [Help]

    Please Help me!


    Wednesday, August 12, 2015 11:18 PM


  • Greetings,

    Thank you for posting here, I suspect that Remote Desktop Connection is turned OFF (“Don’t allow remote connections to this computer”) in the Remote Desktop settings or Remote Desktop in Windows Firewall is disabled on the Azure Virtual Machine, you can use the cmdlets below to enable RDP and the necessary Windows firewall rule for the Azure Virtual Machine

    netsh advfirewall firewall set rule group="remote desktop" new enable=Yes

     Try above solution and let us know whether it resolves the issue. 


    • Proposed as answer by Shreya Hajela Saturday, August 15, 2015 6:48 AM
    • Marked as answer by Girish Prajwal Sunday, August 16, 2015 1:41 PM
    Thursday, August 13, 2015 3:05 AM