none
Oracle WCF LOB Adapter with BTS 2009 64 bit RRS feed

  • Question

  • I am working with a customer on installing Oracle WCF LOB Adapter on a 64 bit install of BTS 2009.

    We are having problems with the Oracle client requirements, the latest error message showing below:

    Oracle.DataAccess.Client.OracleException The provider is not compatible with the version of Oracle client 

    We first went with the install guide, which specifies:

  • Install both the 32-bit and 64-bit versions of the Oracle client 10.2.0.3.
  • Install both 32-bit and 64-bit versions of ODP.NET.
    • For 32-bit: Oracle Data Provider for .NET 2.0, 10.2.0.2.20 (ODP.NET 2.0).
    • For 64-bit: Oracle Data Provider for .NET 2.0, 10.2.0.3.02

    We were getting similar errors as above, so found this troubleshooting guidance (http://msdn.microsoft.com/en-us/library/dd787836(BTS.10).aspx) which states:

  • Install both the 32-bit and 64-bit versions of the BizTalk Adapter Pack on a 64-bit WCF LOB Adapter SDK installation.
  • Install both the 32-bit and 64-bit versions of the Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7.

    We then upgrade the Oracle client and ODAC to the 11 version and still get errors.
  • Can you please clarify precisely which Oracle client versions are required along with the ODP versions?

    Also, the whole 32 + 64 bit Oracle Client installation requirements are difficult to justify. Is there any guidance on best practices (directory names, paths, etc) for deploying these side by side?

    Thanks.


    Rick MVP, Connected Systems Developer
Tuesday, October 20, 2009 6:18 PM

All replies