none
Unattended installation from USB and reboot during installation RRS feed

  • Question

  • I've made an unattended installation, from USB to set up WES7 to my system. During installation the system has to restart.

     

    When installing from a DVD (made from the same ICE output as on my USB drive) the question appears if I'd like to boot from DVD. If there isn't an answer in ca. 10 seconds the system boots from the HDD, finishing the installation.

     

    When installing from USB, the (unattended) installer starts all over again... Is there a way to stop the installer from installing for the second time, eq. giving the same question as the dvd?

    Monday, October 25, 2010 11:15 AM

Answers

  • I just don't accept on of the license agreements in the answer file so that I'm prompted every time Windows wants to install.  So, I accept the license the first time through.  When the system reboots I see the prompt again but I don't accept.  This causes the system to reboot and gives me time to unplug the USB flash drive
    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Monday, October 25, 2010 3:41 PM
  • Another Workaround could be using a chainloader. e.g. grub. boot from usb. you create a menu/list and select using primary hdd as default with timeout (like "press any key"). second option would be booting the bootmgr on usb drive. this is nearly the same as the cd/dvd methode.
    "Mark/Propose As Answer" if you got one.
    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Monday, October 25, 2010 4:54 PM
  • It seems that bootfix.bin isn't working on USB, so I'll go for beemr007's solution. When making a "production" stick I'll go for the boot manager...

     

    Thanks all for the replies.

    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Tuesday, October 26, 2010 6:39 AM

All replies

  • i don't know if bootfix.bin or something works on usb drive, but the easiest way would be to set the hdd as primiray boot and select usb drive once for install in boot-menu (F9/F12). after win7 reboots the hdd will startup.
    "Mark/Propose As Answer" if you got one.
    Monday, October 25, 2010 1:07 PM
  • I just don't accept on of the license agreements in the answer file so that I'm prompted every time Windows wants to install.  So, I accept the license the first time through.  When the system reboots I see the prompt again but I don't accept.  This causes the system to reboot and gives me time to unplug the USB flash drive
    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Monday, October 25, 2010 3:41 PM
  • Unfortunately most computers treat booting from USB and from CD/DVD differently. You'll notice that when you have a DVD inserted, you'll get a message saying "Press any key to boot from DVD...", but this doesn't happen for USB drives. This is why DVDs won't have the looping reboot/install problem while USB drives will.

    The workarounds listed by KNARZ and beemr007 are your best options. Either have your hard drive configured to boot first, or leave out some information in your answer file so that installation doesn't happen automatically.

    Monday, October 25, 2010 4:20 PM
  • Another Workaround could be using a chainloader. e.g. grub. boot from usb. you create a menu/list and select using primary hdd as default with timeout (like "press any key"). second option would be booting the bootmgr on usb drive. this is nearly the same as the cd/dvd methode.
    "Mark/Propose As Answer" if you got one.
    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Monday, October 25, 2010 4:54 PM
  • It seems that bootfix.bin isn't working on USB, so I'll go for beemr007's solution. When making a "production" stick I'll go for the boot manager...

     

    Thanks all for the replies.

    • Marked as answer by SanderB1234 Tuesday, October 26, 2010 6:41 AM
    Tuesday, October 26, 2010 6:39 AM