locked
Interactive Designer Setup (db_cooper1950) - 6/2/2006 1:06 PM PST RRS feed

  • Question

  • By: db_cooper1950

    I am trying to install the March 2006 CTP of Expression Interactive Designer 
    and I receive an error / information box saying that I need Windows 
    Presentation Foundation build 6.0.5295.60113, before it will install. Which 
    my registry says I have:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinFX RunTime\Windows Presentation 
    Foundation\v3.0 = {6.0.5378.0 (vbl_wcp_avalon.060427-1623)}
    
    My questions are:
    1.) The Program cannot use a newer runtime component? 
    2.) The runtime components are not backward compatable?
    3.) Is there a fix for this?
    
    Thanks,
    db_cooper1950
    Tuesday, February 19, 2008 12:46 AM

Answers

  • By: Unni Ravindranathan (MS)

    Also, just to add a note about backward compatibility - all this is only
    true for the CTP and Beta releases. Once WinFX ships, EID should be able to
    run without re-installing even if there are service packs for WinFX (hence
    in essence being revved up from 3.0 to 3.1).

    Thanks,
    -Unni
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Lingesh Palaniappan (MS)" <lipalani@microsoft.com> wrote in message
    news:%23K$xGJohGHA.896@TK2MSFTNGP02.phx.gbl...
    > Hi,
    > Each CTP of EID is tied to a specific Win FX. It does not work on any
    > other builds of Win FX or WPF.
    >
    > I think the only option is to uninstall your win FX and install the one
    > mentioned in our download web page:
    >
    >
    http://www.microsoft.com/products/expression/en/interactive_designer/id_free_trial.aspx
    >
    > regards,
    > Lingesh
    > "db_cooper1950" <dbcooper1950@discussions.microsoft.com> wrote in message
    > news:DEC8EB1E-2065-42B5-8CEC-4FE384236AD0@microsoft.com...
    >>I am trying to install the March 2006 CTP of Expression Interactive
    >>Designer
    >> and I receive an error / information box saying that I need Windows
    >> Presentation Foundation build 6.0.5295.60113, before it will install.
    >> Which
    >> my registry says I have:
    >> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinFX RunTime\Windows Presentation
    >> Foundation\v3.0 = {6.0.5378.0 (vbl_wcp_avalon.060427-1623)}
    >>
    >> My questions are:
    >> 1.) The Program cannot use a newer runtime component?
    >> 2.) The runtime components are not backward compatable?
    >> 3.) Is there a fix for this?
    >>
    >> Thanks,
    >> db_cooper1950
    >
    >

    Tuesday, February 19, 2008 5:49 PM

All replies

  • By: Lingesh Palaniappan (MS)

    Hi,
    Each CTP of EID is tied to a specific Win FX. It does not work on any other 
    builds of Win FX or WPF.
    
    I think the only option is to uninstall your win FX and install the one 
    mentioned in our download web page:
    
    http://www.microsoft.com/products/expression/en/interactive_designer/id_free_trial.aspx
    
    regards,
    Lingesh
    "db_cooper1950" <dbcooper1950@discussions.microsoft.com> wrote in message 
    news:DEC8EB1E-2065-42B5-8CEC-4FE384236AD0@microsoft.com...
    >I am trying to install the March 2006 CTP of Expression Interactive 
    >Designer
    > and I receive an error / information box saying that I need Windows
    > Presentation Foundation build 6.0.5295.60113, before it will install. 
    > Which
    > my registry says I have:
    > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinFX RunTime\Windows Presentation
    > Foundation\v3.0 = {6.0.5378.0 (vbl_wcp_avalon.060427-1623)}
    >
    > My questions are:
    > 1.) The Program cannot use a newer runtime component?
    > 2.) The runtime components are not backward compatable?
    > 3.) Is there a fix for this?
    >
    > Thanks,
    > db_cooper1950 
    
    
    
    Tuesday, February 19, 2008 5:49 PM
  • By: Unni Ravindranathan (MS)

    Also, just to add a note about backward compatibility - all this is only
    true for the CTP and Beta releases. Once WinFX ships, EID should be able to
    run without re-installing even if there are service packs for WinFX (hence
    in essence being revved up from 3.0 to 3.1).

    Thanks,
    -Unni
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Lingesh Palaniappan (MS)" <lipalani@microsoft.com> wrote in message
    news:%23K$xGJohGHA.896@TK2MSFTNGP02.phx.gbl...
    > Hi,
    > Each CTP of EID is tied to a specific Win FX. It does not work on any
    > other builds of Win FX or WPF.
    >
    > I think the only option is to uninstall your win FX and install the one
    > mentioned in our download web page:
    >
    >
    http://www.microsoft.com/products/expression/en/interactive_designer/id_free_trial.aspx
    >
    > regards,
    > Lingesh
    > "db_cooper1950" <dbcooper1950@discussions.microsoft.com> wrote in message
    > news:DEC8EB1E-2065-42B5-8CEC-4FE384236AD0@microsoft.com...
    >>I am trying to install the March 2006 CTP of Expression Interactive
    >>Designer
    >> and I receive an error / information box saying that I need Windows
    >> Presentation Foundation build 6.0.5295.60113, before it will install.
    >> Which
    >> my registry says I have:
    >> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinFX RunTime\Windows Presentation
    >> Foundation\v3.0 = {6.0.5378.0 (vbl_wcp_avalon.060427-1623)}
    >>
    >> My questions are:
    >> 1.) The Program cannot use a newer runtime component?
    >> 2.) The runtime components are not backward compatable?
    >> 3.) Is there a fix for this?
    >>
    >> Thanks,
    >> db_cooper1950
    >
    >

    Tuesday, February 19, 2008 5:49 PM
  • By: db_cooper1950

    I do understand Beta versions and I fugured that I would hear exactly what 
    you have told me.  I was just hoping that there was a work around that I 
    could implement, but hey it's free so no problem.  I want to thank both Unni 
    & Lingesh for their prompt responses, and wish you both a great day and happy 
    designing!
    My regards,
    Dave
    
    "Unni Ravindranathan (MS)" wrote:
    
    > Also, just to add a note about backward compatibility - all this is only 
    > true for the CTP and Beta releases. Once WinFX ships, EID should be able to 
    > run without re-installing even if there are service packs for WinFX (hence 
    > in essence being revved up from 3.0 to 3.1).
    > 
    > Thanks,
    > -Unni
    > -- 
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    > 
    > "Lingesh Palaniappan (MS)" <lipalani@microsoft.com> wrote in message 
    > news:%23K$xGJohGHA.896@TK2MSFTNGP02.phx.gbl...
    > > Hi,
    > > Each CTP of EID is tied to a specific Win FX. It does not work on any 
    > > other builds of Win FX or WPF.
    > >
    > > I think the only option is to uninstall your win FX and install the one 
    > > mentioned in our download web page:
    > >
    > > http://www.microsoft.com/products/expression/en/interactive_designer/id_free_trial.aspx
    > >
    > > regards,
    > > Lingesh
    > > "db_cooper1950" <dbcooper1950@discussions.microsoft.com> wrote in message 
    > > news:DEC8EB1E-2065-42B5-8CEC-4FE384236AD0@microsoft.com...
    > >>I am trying to install the March 2006 CTP of Expression Interactive 
    > >>Designer
    > >> and I receive an error / information box saying that I need Windows
    > >> Presentation Foundation build 6.0.5295.60113, before it will install. 
    > >> Which
    > >> my registry says I have:
    > >> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WinFX RunTime\Windows Presentation
    > >> Foundation\v3.0 = {6.0.5378.0 (vbl_wcp_avalon.060427-1623)}
    > >>
    > >> My questions are:
    > >> 1.) The Program cannot use a newer runtime component?
    > >> 2.) The runtime components are not backward compatable?
    > >> 3.) Is there a fix for this?
    > >>
    > >> Thanks,
    > >> db_cooper1950
    > >
    > > 
    > 
    > 
    > 
    Tuesday, February 19, 2008 5:50 PM