locked
Server Driven Paging RRS feed

  • Question

  • I feel really stupid asking but I have just installed Data Services Update for .NET 3.5 SP1 hoping to see config.SetEntitySetPageSize, but it is not defined in IDataServiceConfiguration. I checked that I have the right version of System.data.services.dll.


    Dick Page
    Thursday, December 17, 2009 8:59 AM

Answers

  • Hi,

    We could not change the VS file template for backward compatibility reasons, that's why you see IDataServiceConfiguration. But the V2 also supports the InitializeService method with a DataServiceConfiguration parameter (without the I) which does have the method you're looking for. So simply delete the I letter from the parameter declaration and everything should just work.
    In VS2010 the template already contains the newer version.
    Also note that most of the V2 features are disabled by default (backward compat and security reasons). So you may need to enable it by using config.DataServiceBehavior and its properties.

    Thanks,
    Vitek Karas [MSFT]
    • Marked as answer by dickP Thursday, December 17, 2009 11:46 AM
    Thursday, December 17, 2009 10:54 AM
    Moderator

All replies

  • Hi,

    We could not change the VS file template for backward compatibility reasons, that's why you see IDataServiceConfiguration. But the V2 also supports the InitializeService method with a DataServiceConfiguration parameter (without the I) which does have the method you're looking for. So simply delete the I letter from the parameter declaration and everything should just work.
    In VS2010 the template already contains the newer version.
    Also note that most of the V2 features are disabled by default (backward compat and security reasons). So you may need to enable it by using config.DataServiceBehavior and its properties.

    Thanks,
    Vitek Karas [MSFT]
    • Marked as answer by dickP Thursday, December 17, 2009 11:46 AM
    Thursday, December 17, 2009 10:54 AM
    Moderator
  • That does it thanks.
    Dick Page
    Thursday, December 17, 2009 11:47 AM