locked
WebBrowser and illegal operation? RRS feed

  • Question

  • I have a form with a WebBrowser object.  When I navigate to certain sites I see the content start to load and then the form shuts down with a fatal application error saying that my application has performed an illegal operation (exception 0xC00000FD).  These same sites load fine in IE.

    This is all on a Windows CE 5.0 device with Compact Framework 2.0 SP2 on it.

    Can anyone help with this?  I saw an old post from 2005, but no answers.

    Two URLs this always happens with:

    http://www.flags.net
    http://www.whitehouse.gov/history/presidents/al16.html
    Monday, July 30, 2007 7:15 PM

Answers

  • I tried the above urls on a PPC 2003 device and it worked fine. Also doing a bit of searching online I came across this post (http://groups.google.nl/group/microsoft.public.windowsce.embedded.vc/msg/85846abacdb6768e). It might be that on CE 5.0 devices, we are just running out of stack space due to something large in the web page. The reason it could have worked on PPC 2003 might be due to a different implementation of the native web browser control.

     

    Unfortunately the workaround presented in the post above does not hold for netcf since we lock down the use of 64 k stack space for the main thread. You could try putting the GUI thread on a seperate thread than the main thread... so in the main thread you don't call Application.Run() but instead all you do is create another thread with a large stack space and call Application.Run() in that thread that you created. Hopefully this should give you enough stack to play with and should solve your problem if stack space is the issue.

     

    Thanks,

    Sandy

    Tuesday, July 31, 2007 6:54 PM