locked
Metro IE10 Gone :(

    Question

  • Just like that... All the sudden the IE tile started launching the ie desktop app, and searching for apps also brings only the desktop app...

     

    The only thing i did that could remotely cause this was uninstalling powerpoint viewer to be able to install Office 2010 64 bit...

    Friday, September 16, 2011 5:23 AM

Answers

  • I had the same problem. The trick is to make sure you set Internet Explorer as the Default Internet browser from within the "Default Programs" control panel. It doesn't seem to work if you try to set it as default from within IE itself.
    Just follow the exact instructions below.

    From the Metro Start Screen search for (by typing) "Default Programs" with the "Apps" category on the right selected.

    Open "Default Programs"

    Open "Set your Default Programs"

    Select "Internet Explorer" under the Programs list on the left

    Click "Set this program as default"

    Close "Set Default Programs"

    again, from the Metro Start Screen search for Internet Explorer

    When the Search result for Internet Explorer appears on the left, Right click it and choose "Pin"

    The Tile should appear again, probably at the far right

    • Proposed as answer by BranM Friday, September 16, 2011 7:28 AM
    • Marked as answer by LukasTaves Friday, September 16, 2011 2:49 PM
    Friday, September 16, 2011 7:28 AM
  • I had the same problem. The trick is to make sure you set Internet Explorer as the Default Internet browser from within the "Default Programs" control panel. It doesn't seem to work if you try to set it as default from within IE itself.
    Just follow the exact instructions below.

    From the Metro Start Screen search for (by typing) "Default Programs" with the "Apps" category on the right selected.

    Open "Default Programs"

    Open "Set your Default Programs"

    Select "Internet Explorer" under the Programs list on the left

    Click "Set this program as default"

    Close "Set Default Programs"

    again, from the Metro Start Screen search for Internet Explorer

    When the Search result for Internet Explorer appears on the left, Right click it and choose "Pin"

    The Tile should appear again, probably at the far right


    Thank you, the tile itself wasn't gone, but even thought the metro ie was pinned, it kept launching the desktop version... But setting it to default solved it :P

     

    Thank you!

    Friday, September 16, 2011 2:51 PM

All replies

  • If you set a browser other than IE10 as default then the metro IE will not launch. Not sure if its a bug or intended. Set IE back to default then the metro IE should start working again.
    Friday, September 16, 2011 6:08 AM
  • If you set a browser other than IE10 as default then the metro IE will not launch.
    Not so.  Firefox is my default browser, yet I can still access Metro IE10.  In fact, some things, like the desktop weather gadget, still open to Metro IE instead of opening to my default browser.
    Friday, September 16, 2011 6:26 AM
  • I had the same problem. The trick is to make sure you set Internet Explorer as the Default Internet browser from within the "Default Programs" control panel. It doesn't seem to work if you try to set it as default from within IE itself.
    Just follow the exact instructions below.

    From the Metro Start Screen search for (by typing) "Default Programs" with the "Apps" category on the right selected.

    Open "Default Programs"

    Open "Set your Default Programs"

    Select "Internet Explorer" under the Programs list on the left

    Click "Set this program as default"

    Close "Set Default Programs"

    again, from the Metro Start Screen search for Internet Explorer

    When the Search result for Internet Explorer appears on the left, Right click it and choose "Pin"

    The Tile should appear again, probably at the far right

    • Proposed as answer by BranM Friday, September 16, 2011 7:28 AM
    • Marked as answer by LukasTaves Friday, September 16, 2011 2:49 PM
    Friday, September 16, 2011 7:28 AM
  • I haven't installed anything or made any changes and all of the sudden when I click on metro IE, it launches into the desktop version.  I will try to go set it as default as suggested and let you know what happens but it should already be default.
    Friday, September 16, 2011 12:22 PM
  • I had the same problem. The trick is to make sure you set Internet Explorer as the Default Internet browser from within the "Default Programs" control panel. It doesn't seem to work if you try to set it as default from within IE itself.
    Just follow the exact instructions below.

    From the Metro Start Screen search for (by typing) "Default Programs" with the "Apps" category on the right selected.

    Open "Default Programs"

    Open "Set your Default Programs"

    Select "Internet Explorer" under the Programs list on the left

    Click "Set this program as default"

    Close "Set Default Programs"

    again, from the Metro Start Screen search for Internet Explorer

    When the Search result for Internet Explorer appears on the left, Right click it and choose "Pin"

    The Tile should appear again, probably at the far right


    Thank you, the tile itself wasn't gone, but even thought the metro ie was pinned, it kept launching the desktop version... But setting it to default solved it :P

     

    Thank you!

    Friday, September 16, 2011 2:51 PM
  • i asked this question a few days ago and nobody helped lol but this worked... thanks! :)
    Friday, September 16, 2011 2:57 PM
  • Thank you soooooo much! I have been trying to find a fix for this for a week now! 
    Wednesday, September 28, 2011 1:54 AM
  • I suspect you're confused-- Metro IE is only available if IE is your default browser. Note that pushing "make default" in Firefox (or any other browser) will not make it the default. As a part of larger registration changes in Windows 8, you can only use Windows UI to set defaults, and no application may set itself as a default. (That's why the "Make default" buttons were removed from IE10.)

    Thursday, October 20, 2011 9:21 PM
  • Hi spamatron,

    Due to changes in default file association in the Developer's Preview, Firefox will not be truly your default browser unless you go into control panel and set it as your default browser there.  That is why Metro IE still works for you and links are still opening up in IE instead of Firefox.

    Friday, October 21, 2011 5:33 AM