Expressions Web Design Software and FTP RRS feed

  • Question

  • User592521714 posted

    If I am missing something here, someone please correct me, but I think there might be an issue with logging on to FTP on IIS 7 using Expressions.

    Logging on to FTP in IIS 7 requires the user name to be expressed as "domain|username".

    However Expressions Web will not accept the "|" character in the user name field.

    Is there another way to logon to FTP using Expressions that I am not aware of?




    Tuesday, December 18, 2007 5:28 PM


All replies

  • User1073881637 posted

    Usually you login as Domain\Username (backslash).  The pipe is not the separator for domain logins.

    Tuesday, December 18, 2007 10:55 PM
  • User592521714 posted

    Thanks for your input Steve, usually that would be the case, and certainly in IIS 6.0 it is; but not in IIS 7.0, which uses what I would call 'host headers' for ftp as well as http if you use 'all unassigned' when setting up the site and adding ftp to the web site.

    Setting up a unique ftp site with its own IP address would function pretty much the same as IIS 6.0, i.e. domain\username, but IIS 7.0 requires the format I indicated above when adding the FTP site to an HTTP site and using 'all unassigned'.


    Tuesday, December 18, 2007 11:49 PM
  • User1073881637 posted

    I don't quite agree with your statement. :)  The Pipe symbol is not a delimiter for logins or I've never seen them used in AD.  I setup an IIS 7.0 and FTP site (using the IIS 7.0 Publishing service).  Both had All Unassigned configured in the bindings, and I was able to use a domain\username account.  I'm using CoreFTP and FileZilla to connection and not Expression, but FTP is well, FTP.  I was able to use FTP over SSL and plain FTP. 

    When I try a 'ftp' host header, I'm getting 550 Host not found.   I tried using an FTP client right on the server, no go.  I even got the 534 TLS error others have posted, which is cool, I don't know the answer yet, but I know how to reproduce the error.  I'm not quite sure how FTP host-headers work under the covers, I even tried putting the entry in the hosts to do a resolution lookup.  I can ping the A record, do an NSLOOKUP to the 'ftptest' host name I'm using.  DNS is clean, the AD account is good, the account I'm using is a 'domain admin'. 

    Here is the error I get from my FTP client. 

    Mem -- 523,752 KB, Virt -- 2,097,024 KB
    Started on Tuesday December 18, 2007 at 22:31:PM
    Resolving ftptest.aspdot.net... 
    Connect socket #644 to, port 21...
    220 Microsoft FTP Service 
    USER aspdot\testuser 
    550-No such host is known.  
     Win32 error:   No such host is known.  
     Error details: Hostname didn't match any configured ftp site. 
    550 End 

    I'm going to see what I can find.  I'd be curious if others have been able to use FTP host headers?!  Stay tuned...

    Wednesday, December 19, 2007 1:37 AM
  • User592521714 posted

    Check out the bottom of this page: http://www.iis.net/articles/view.aspx/IIS7/Managing-IIS7/Using-FTP-Server-in-IIS7/Using-virtual-host-names?Page=2

    You need to use the format of sitename|username


    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, December 19, 2007 1:59 AM
  • User1073881637 posted

    Yea, I seen that article.  I apologize for my statement, I had't messed with FTP host headers, so I'm learning, that is where you would use the Pipe symbol.  :)   I made some progress since my last post.  I'm able to use a domain admin user with an FTP host-header and connect using plain FTP.

    I use hostname|domain\username, password in an FTP client (CoreFTP and FileZilla).  Your problem might be specific with Expression, which I can't test since I don't have it loaded on my system.  The only thing I haven't gotten yet is an FTP host headered site, with SSL enabled.  I get this error, if I use straight FTP, it works like a champ. 

    With SSL enabled, no go.  I'm not sure why this is happening.  But I'll sure try. Stay tuned....
    534 Local policy on server does not allow TLS secure connections.
    Error: Critical error
    Error: Could not connect to server

    Without SSL enabled and using a host-headered FTP site.
    Status: Resolving IP-Address for ftptest.aspdot.net
    Status: Connecting to
    Status: Connection established, waiting for welcome message...
    Response: 220 Microsoft FTP Service
    Command: USER ftptest.aspdot.net|aspdot\testuser
    Response: 331 Password required for ftptest.aspdot.net|aspdot\testuser
    Command: PASS **************
    Response: 230 User aspdot\testuser logged in.
    Command: OPTS UTF8 ON
    Response: 200 OPTS UTF8 command successful - UTF8 encoding now ON.
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is current directory.
    Status: Directory listing successful

    You might want to try a plain FTP client at first then isolate it to Expression.

    Wednesday, December 19, 2007 2:10 AM
  • User1073881637 posted

    Ha! I got SSL working with FTP host-headered site.  The one thing that solved the 534 TLS error was I had to define an SSL certificate on the 'root' settings.   I had 'All Assigned' defined on the HTTP and FTP bindings.  This is way cool stuff MS!

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, December 19, 2007 2:18 AM
  • User592521714 posted

    Glad you got it working. I haven't had to enter a domain name prefix in front of the user name with any ftp sites I have setup. I have added the domain here: FTP AUTHENTICATION | Basic Authentication | Edit, so maybe that is why I don't need to enter it to logon. All of may accounts are domain accounts.

    Frankly, I haven't played around with SSL and FTP yet. The problem I'm trying to work through now is getting an FTP site with a UNC file path to work. :(


    Wednesday, December 19, 2007 11:11 AM
  • User1073881637 posted

    Hi John,

    I've wanted to learn more about the FTP 7.0 publishing product, your post made me dig a bit, but it has been worthwhile.  Makes sense you are setting the domain property, that is a good way to cutdown on user questions.  :)  Regarding mapping a UNC path.  Are you mapping the root folder or a virtual directory?  I've not done a root folder, but it should be similar to the process of doing an vdir.

    1) create a virtual directory mapped to a unc source
     a) either use a static domain user to authenticate as
     b) use pass through authentication
    2) Set in the FTP Directory Browsing so 'virtual directories showup
    3) Test from a remote machine with an FTP account, the vdir (mapped to a unc path) should show-up. 

    I tested this with a ftp host-headered site and it worked as designed, just make sure the pass through authentication user has permissions on the remote share / resource.

    The only thing I can't figure out is mapping external authentication modules that aren't necessarily an windows account.  I'm hoping Robert M (program manager for FTP) pops in and checks out the post.  He'll have lots of good info to share. I think he wrote the article you pointed out.

    Good luck.

    Wednesday, December 19, 2007 12:29 PM
  • User-1853252149 posted

    The only thing I can't figure out is mapping external authentication modules that aren't necessarily an windows account. 

    If I remember, the only two accounts you can use are Windows or an IIS account.  AFAIK FTP doesn't accept other accounts, such as ASP.NET membership accounts.


    Wednesday, December 19, 2007 1:00 PM
  • User1862224703 posted

    I am having the same problem all of a sudden.  The ftp worked fine for months.. Does your Expressions tell you to open site using an HTTP Url? and  Did you get an answer back yet?  If so please share.


    Wednesday, May 5, 2010 4:01 PM
  • User-92718035 posted

    The one thing that solved the 534 TLS error was I had to define an SSL certificate on the 'root' settings.   I had 'All Assigned' defined on the HTTP and FTP bindings.

    Thanks for the tip! It helped me after 2 hours surfing the web.
    Friday, October 15, 2010 4:19 AM