none
Monitor goes sleep all the time RRS feed

  • Question

  • Hello all,

    I have WES7 image (licensed, x86, SP1) where I need my monitor keep always on.

    I run powercfg -change -monitor-timeout-ac 0 command and double checked in the control panel that "Turn off display:" is set to "Never" in the current power plan.

    However the monitor goes asleep in 20 minutes of idle time. If I move a mouse it comes back.

    What else should I change to make monitor on permanently?

    Thanks in advance,

    Nikolai


    WBR, Nikolai

    • Changed type NickViz Friday, April 20, 2012 10:16 AM Problem still exists
    Thursday, March 1, 2012 4:17 PM

All replies

  • To isolate any hardware issues, does the monitor show the same behavior when connected to a Windows 7?

    Is there special video driver utilities included in the image?

    Does the monitor have any timeout settings?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Thursday, March 1, 2012 9:39 PM
    Moderator
  • Hello Sean,

    well, it's a usual CRT monitor, XPe on this hardware doesn't make any problem.

    Strangely enough - it looks like the 

    powercfg -X -monitor-timeout-ac 0

    command doesn't actually make monitor permanently on, but the

    powercfg -change -monitor-timeout-ac 0

    actually works, even if powercfg help stands that "-change (-X)" as the same command.

    Quite weird, indeed.

    Nikolai.


    WBR, Nikolai

    Monday, March 5, 2012 3:24 PM
  • I have never used the -X option. Do you have it set properly now?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Monday, March 5, 2012 4:07 PM
    Moderator
  • quite weird.

    A single powercfg -change -monitor-timeout-ac 0 after first boot doesn't work, but when I run

    powercfg -change -monitor-timeout-ac 0
    powercfg -change -monitor-timeout-dc 0
    powercfg -change -disk-timeout-ac 0
    powercfg -change -disk-timeout-dc 0
    powercfg -change -standby-timeout-ac 0
    powercfg -change -standby-timeout-dc 0
    powercfg -change -hibernate-timeout-ac 0
    powercfg -change -hibernate-timeout-dc 0

    3 times with some reboot and relogon - it started to work somehow reliable.

    Nikolai.


    WBR, Nikolai

    • Marked as answer by NickViz Tuesday, March 13, 2012 10:17 AM
    Thursday, March 8, 2012 2:54 PM
  • By any chance was screen saver enabled?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Thursday, March 8, 2012 4:45 PM
    Moderator
  • by default screen saver set to None, rechecked power plan from there - 'Turn off display" set to Never.

    Again - it works, but only after I execute all possible commands 3 times.

    I've started think that it might be whole machine goes asleep and my standby- commands fixed it.


    WBR, Nikolai

    Thursday, March 8, 2012 4:49 PM
  • Actually it didn't completely help.

    On some machines it works, but on some other - not. I'm running set of commands upstairs even 3 times - but monitor still goes asleep. Do't know what to do actually...


    WBR, Nikolai

    Wednesday, April 11, 2012 1:13 PM
  • I have struggled with the same problem and start to think there is a bug in the powercfg command when trying to set "never turn off monitor". 'POWERCFG -Change -monitor-timeout-ac 0' works sometimes but mostly not, the monitor turns off after 20 minutes. I have turned off all power save options in the BIOS and used 'powercfg -setacvalueindex xxx yyy " to turn off all other power saving features in windows. I have also checked that the graphics card does not have its own power save settings. I want to use the powercfg command in powershell scritps running as RunSynchronousCommand during windows installation (WES7 SP1 x86). I have done several installations of the same WES7 image on the same machine. Only for a few of these cases does the monitor stays after a long time of inactivity. For those installations were the setting takes effect will it work all the time, after reboot and so on.

    The way I get around this is to set the timeout to a very high number instead of 0 (which should mean 'never'), like

    POWERCFG -Change -monitor-timeout-ac 525600 # 525600 minutes = 1 year

    The other settings I use seem to work always
        POWERCFG -CHANGE -disk-timeout-ac 0
        POWERCFG -CHANGE -standby-timeout-ac 0
        POWERCFG -CHANGE -hibernate-timeout-ac 0
    so I think the problem is specific for 'powercfg -change -monitor-timeout-ac'(don't know how it is with the dc variants).

    • Marked as answer by NickViz Monday, July 16, 2012 9:23 AM
    • Unmarked as answer by NickViz Monday, July 23, 2012 7:36 AM
    Friday, June 29, 2012 2:37 PM
  • Hello podprevas,

    it looks like a solution. I checked it and it seems to work OK. Thanks for the info.

    Nikolai


    WBR, Nikolai

    Monday, July 16, 2012 9:24 AM
  • Since our application only works in "high performance" mode at the moment:

    control panel -> power options ->...

    change the power mode to "high performance"

    change the power button to "shutdown" (its QM chipset and thus 7 thinks it's a laptop!)

    change the screen sleep time to "never"

    Obviously there is a CLI command to do this, but other people seem to have problems with it. I'll give it a try though.


    =^x^=

    Monday, July 23, 2012 7:15 AM