locked
VS-Exec without debugging give the content of my .asmx file in the navigator :( RRS feed

  • Question

  • User1551274504 posted

    Hi everybody,

    I am trying to execute a Web Service file in ASP.NET with Visual Studio 2005, Professionnal Edition and it doesn't work. The Ctrl +F5 gives the content of the .asmx file in the navigator. 

    <%@ WebService Language="C#" CodeBehind="MyDirectory/AppCode/MyFile.cs" Class="MyClass" %>

    I really neeed some help :(

    I have to mention that i am using Windows 8 so, IIS 8.0 gaves me a lot of trouble and i tried my best to configure it with support of .Net 2.0 (Activate .net 3.5, add script mapping Handlers for *.soap, *.aspx, *.asmx, change the permissions to be able to run\debug it in machine.config etc..). 

    Sorry if my english is not very good and thank you for your help :)

    Monday, January 7, 2013 3:37 PM

Answers

  • User-166373564 posted

    Hi,

    Welcome to ASP.NET Forums.

    These tutorials are available for you to configure an ASP.NET Website on IIS,

    To install an IIS web server and configure it for ASP.NET web applications, follow the steps listed.

    Step 1: Install IIS and ASP.NET Modules

    Step 2: Configure ASP.NET Settings

    Step 3: Configure Data Source Settings

    Step 4: Configure Application Security

    You could learn detailed information about configure an ASP.NET Website on IIS here.

    hope it helps you,

    Kind regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 14, 2013 6:40 AM