locked
Have code for vs2005 for pocketpc 5.01, dev'ing on win7 64b - how to get solution to open? RRS feed

  • Question

  • Hi all,

    I was handed a vs2005 solution to make some changes. The upgrade to vs2010 failed, so I installed vs2005. On loading the projects, I received various load failures talking about "device platform does not exist in your datastore". So I went through the various csproj files and saw they targeted pocketpc 5.01. So I went and downloaded that sdk. Tried to install it, and it failed, telling me I need activesync 4.0. So I went and downloaded that. Tried to install it, and it wouldn't run, win7 telling me that the installer has compatibility issues.

    edit: I have tried running the activesync setup.exe in various compatibility modes from xpsp3 down to win2k. All fail.

    So what do I need to do to get a functioning dev environment for this code?

    /me sighs

    Thanks for any tips,

    -sff

    Wednesday, March 9, 2011 4:44 PM

Answers

All replies

  • VS2010 does not support the Windows Mobile or Windows CE platforms. You will need VS2008 or earlier.

    In Win7 you need to install:
    1. Visual Studio 2008 (or 2005)
    2. Windows Mobile Device Center http://www.microsoft.com/downloads/en/details.aspx?FamilyID=46f72df1-e46a-4a5f-a791-09f07aaa1914&displayLang=en
    3. Windows Mobile 6 SDK (or WM5 SDK depending on what device you want this to run on)

    Then you should be able to open your project and have it update successfully.

    -PaulH

    Wednesday, March 9, 2011 8:57 PM
  • I'm pretty sure I very clearly said I INSTALLED VS2005.

    Pro tip: answers are more helpful when one reads the person's situation.
    Wednesday, March 9, 2011 9:04 PM
  •  

    Hello,

     

    Running Visual Studio 2005 on Windows 7, you should install

    Microsoft® Visual Studio® 2005 Team Suite Service Pack 1 firstly, and then install

    Visual Studio 2005 Service Pack 1 Update for Windows Vista

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Jesse Jiang Tuesday, March 22, 2011 7:48 AM
    Friday, March 11, 2011 3:16 AM
  •  

    Hi,

     

    I'm very interested in hearing more about your issue, did you solve your problem?

    If so please share the solution with us and mark the right answers.

    If not please let me know and I will tray to help you find further solutions.

     

    Have a nice day!

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, March 18, 2011 9:22 AM
  • Actually I would say that answer was helpful. The missing link is in the item #2. Active Sync was replaced with WMDC starting Vista, so that is what you need.

    So go ahead and install it, that should unblock installation of WM 5 SDK and should allow you to load the project.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Jesse Jiang Tuesday, March 22, 2011 7:48 AM
    Friday, March 18, 2011 4:03 PM