locked
"Loading symbols" never ends... RRS feed

  • Question

  • Hi,

      I have been working on a few projects which use the same dll file and they have been working fine too. Just now, when I run them in debug mode, they get stuck in the step of "loading symbol" for that dll and it never ends, and it is the same in all those projects. I tried to run a project not using the dll and it is fine.

      I searched for this issue and nothing helped. I checked according to some online suggestion, and:

    - I do not have enviornment variable _NT_SYMBOL_PATH

    - I have not set up any break points to those projects..

    - In Menu > Option > Debugging > Symbols, in the list of symbol file location, there is one option "Microsoft symbol server" but it has been left unchecked, and nothing else.

      I use other source of the that dll file and the same happened... I think it is not a problem of the dll itself..

      Is there any ideas to solve it? Would it require any specific background program or services be running?

    Raymond


    • Edited by R_MWKwok Wednesday, October 12, 2016 8:05 AM supplmentary
    Wednesday, October 12, 2016 8:03 AM

Answers

  • You already tried to exclude symbols for dll from automatic loading?
     Specify excluded modules
    https://msdn.microsoft.com/en-us/library/ms241613.aspx
    Any impact on debugging experience?

    With kind regards

    • Marked as answer by R_MWKwok Wednesday, October 12, 2016 9:59 AM
    Wednesday, October 12, 2016 9:09 AM

All replies

  • You already tried to exclude symbols for dll from automatic loading?
     Specify excluded modules
    https://msdn.microsoft.com/en-us/library/ms241613.aspx
    Any impact on debugging experience?

    With kind regards

    • Marked as answer by R_MWKwok Wednesday, October 12, 2016 9:59 AM
    Wednesday, October 12, 2016 9:09 AM
  • Thanks, and adding that dll to the exception list does let me through it. 

    However I still have no ideas why such problem has come, while early this morning it did not happen... And also, I am able to compile it without adding the dll to the exception list on another computer...


    Wednesday, October 12, 2016 9:59 AM
  • 'Symbol Load Information...' (Debug->Windows->Modules - right click respective module) - shows where Visual Studio looks for symbol file.
    Probably there is some hint - after you try a manual loading - same menu 'Load Symbols' -  may work also partially, if you may be able to 'Cancel'  - provided it hangs infinitely and you get some dialog like here:


    With kind regards


    Wednesday, October 12, 2016 10:16 AM