locked
XHTMLAdpaters not rendering custom attributes RRS feed

  • Question

  • User-1184000726 posted

    Hi everyone

    I'm trying to add the 'margin-top' attribute to the css class for the
    body tag - an attribute supported by XHTML-MP, but can't.

    I've made a custom Style class which inherits from Style, registered
    the custom style attributes and passed it into the
    writer.SetBodyStyle(style) method. This happens in the render method
    of my CustomXhtmlPageadapter, which inherits from XhtmlPageAdapter.

    All the attributes from the inherited Style class end up in the css
    class but not the custom attributes. Using a decompiler (new best
    friend), i've found that the internal class, XhtmlStyleClass ONLY
    builds the base class attributes, never any custom ones. What can i
    do? This is driving me nuts.

     Thanks in advance

    Andrew
     

    Sunday, February 18, 2007 6:07 PM

All replies

  • User-1184000726 posted
    I have a work around for this if anyone is niterested.
    Monday, February 19, 2007 5:29 PM
  • User-697947180 posted

    I'd love to know your work-around for this. I haven't dealt with that exact problem, but I'm doing a lot with adapters and this is similar to some issues I've been thinking about lately.

     

    Monday, March 5, 2007 8:07 AM
  • User-25724793 posted

    I would also like to see how you were able to get this to work. I am trying to build a XHTML Mobile 1.0 site with CSS using mobile web forms. Thanks in advance for taking the time to follow up on this post.

    Tuesday, March 6, 2007 5:30 PM