none
.NET Framework 4 Final Result: Installation failed with error code: (0x80070643) RRS feed

  • Question

  • While trying to install Microsoft Visual Studio 2010 i got some errors on .NET framework 4.0, so i tried the standalone .NET 4 installer from microsoft and i got these errors.

    MSI (H:\8c4b5e7f61c15fc5cf9e70de2e\netfx_Extended_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20100924_134502282-MSI_netfx_Extended_x86.msi.txt
    [9/24/2010, 13:51:7]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

    [9/24/2010, 13:51:7] Action complete

    [9/24/2010, 13:51:7]OnFailureBehavior for this item is to Rollback.

    [9/24/2010, 13:51:7] Action complete

    [9/24/2010, 13:51:7]Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation." (Elapsed time: 0 00:06:05).
     

    [9/24/2010, 13:51:7] Action complete
    Friday, September 24, 2010 8:36 AM

Answers

  • Hello,

    You may first download .NET Framework 4.0 from the following page and install to see if this issue still exists: http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    If this issue still exists, What is your OS? If it is Vista or later, follow the two setps shown below and try reinstalling to see if the issue is fixed.

    1. Verify that if you have turned on the feature of .NET Framework.
        (Control Panel - Programs and Features - Turn Windows features on or off - Verify that the box next to Microsoft .NET Framework has been checked)

    2. Use Verification Tool to verify .Net Framework has been installed well on your OS. If .Net Framework cannot be verified on your computer, you can try to follow the steps mentioned in this blog to repair the .NET Framework.

    If the installation still fails, I think we need to collect the logs for further troubleshooting. After collecting logs, you may send vslogs.cab file to me (v-jinfan@microsoft.com)

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 4.0
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, September 27, 2010 3:42 AM
    Moderator

All replies

  • Hello,

    You may first download .NET Framework 4.0 from the following page and install to see if this issue still exists: http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    If this issue still exists, What is your OS? If it is Vista or later, follow the two setps shown below and try reinstalling to see if the issue is fixed.

    1. Verify that if you have turned on the feature of .NET Framework.
        (Control Panel - Programs and Features - Turn Windows features on or off - Verify that the box next to Microsoft .NET Framework has been checked)

    2. Use Verification Tool to verify .Net Framework has been installed well on your OS. If .Net Framework cannot be verified on your computer, you can try to follow the steps mentioned in this blog to repair the .NET Framework.

    If the installation still fails, I think we need to collect the logs for further troubleshooting. After collecting logs, you may send vslogs.cab file to me (v-jinfan@microsoft.com)

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 4.0
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, September 27, 2010 3:42 AM
    Moderator
  • Hi Edward,

    I am having a similar problem and have tried everything listed here, its on a new computer which has had no problems installing anything in the past few weeks that I have had it. 

    I have a load of entries similar to below in my log:

    07/26/11 16:45:01 DDSet_Warning: MsiViewExecute failed

    07/26/11 16:45:01 DDSet_Warning: Could not reserve disk space for mscorlib_dll_x86

    07/26/11 16:45:01 DDSet_Status: component: system_enterpriseservices_dll_x86

    I have over 60GB free disk space, my pc is windows 7 with latest updates/service packs and is 64-Bit.
    Where can I send the vslogs.cab to?
    Bal


    bal
    Tuesday, July 26, 2011 3:50 PM
  • I have the same issue. Lots of work, no solution.
    Wednesday, August 17, 2011 12:55 PM
  • Hello Balgar,

    If you want help with your problem, please start a NEW thread!

    When you do, please provide all details of your issue AND be sure to tell us what Windows version you have.

    Replying to an answered thread, as you have done, means VERY few people will read, or be interested in, your question.

    Wednesday, August 17, 2011 1:18 PM
  • Hello iClubConnect,

    If you want help with your problem, please start a NEW thread!

    When you do, please provide all details of your issue AND be sure to tell us what Windows version you have.

    Replying to an answered thread, as you have done, means VERY few people will read, or be interested in, your question.

    • Proposed as answer by nedo_007 Saturday, October 22, 2011 11:05 AM
    • Unproposed as answer by nedo_007 Saturday, October 22, 2011 11:05 AM
    Wednesday, August 17, 2011 1:18 PM
  • To all those that have this issue, one posible answer is installing this http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=32

    While checking through the logs of the installation i found a reference to this, saying that "WIC" is not installed, and that i should install it and then rerun the .net framework installer. For me it worked :D

     

    Saturday, October 22, 2011 11:08 AM