locked
Unable to view table record in SQL Server database RRS feed

  • Question

  • Hello, I am creating a simple application form using visual studio 2015. I can create database.mdf successfully and create dbo.table successfully. but when i tried to view table by expanding the table icon on the server explorer, the table should be able to show list of table but it didn't show any record and i have no idea why is it like that. please do help me. thanks!



    • Edited by aphyllum08 Friday, July 24, 2015 2:09 PM
    Friday, July 24, 2015 11:24 AM

Answers

All replies

  • Hello,

    Seems you are looking at two different places; the right image looks a a "project database" which is hosted in LocalDB during runtime.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, July 24, 2015 12:19 PM
    Answerer
  • the first pic is only example. mine is the second one but i already updated it so that people don't get confuse. i want to view list of the table but when i expand it, it didn't show any list in table folder. it just like that on the picture above.

    • Edited by aphyllum08 Friday, July 24, 2015 2:11 PM
    Friday, July 24, 2015 2:01 PM
  • Hi aphyllum08,

    Have you refreshed the table list?

    If the issue still persists after refreshing the Tables folder, please right click on the Tables folder, choose 'New Query' , choose your target database in the drop down list and run the CREATE TABLE statement to create table. Then check if you can view the table successfully. For more details, please review the following similar thread.

    http://stackoverflow.com/questions/15618188/cannot-create-new-sql-data-tables-in-visual-studio-express-2012

    Thanks,
    Lydia Zhang


    Lydia Zhang
    TechNet Community Support



    Monday, July 27, 2015 6:49 AM
  • Hello, I already solved this problem. It was my SQL server problem. By the way, thank you all.
    Saturday, August 1, 2015 2:22 AM