none
Unable to sign in to Visual Studio

    Question

  • Hi!

    My trial period has expired a while ago on Visual Studio 2015 Community Edition. Now I'm trying to sign in as requested by the product to continue using the Community Edition, but the sign-in process fails after asking for my MS account details (email and password) with the following message: "Something went wrong and we can't sign you in right now. Please try again later."

    I've searched these forums for answers, but it seems like I have everything that should make it work: I have Internet Explorer 11 installed, I have added https://login.microsoftonline.com/ and https://login.live.com/ to the list of trusted sites, I have made sure Active Scripting is enabled and I have ran a full repair of Visual Studio - yet the problem still persists. Please advise?

    Emmet

    Sunday, March 20, 2016 9:16 PM

Answers

  • Hi Emmet,

    >> I am able to successfully log in to my account on the web - just not from Visual Studio.

    It's so strange and I didn't encounter the same error before. How about using another Microsoft account then try it again?

    In addition, if still no help, since you can sign in it via website. I suppose the cause is still in your Visual Studio. Try to install the VS2015 Update1 the latest update of your Visual Studio.

    In order to check whether the cause is in your VS2015 Community. if possible, I suggest you could install another version of VS like VS2013 Community to check whether it has the same error message when signing it in VS2013.

    Best Regards,

    Lake Xiao

    Monday, March 21, 2016 8:04 AM
    Moderator

All replies

  • Hi Emmet.Mester,

    I recommend you to try to delete the browsing history, clear cache, cookies and try again and if your IE edition is old, please update it to IE 11.

    You can go with these steps to make this work:

    1. Check your connection of the network.

    2. Maybe IE doesn’t trust the Visual Studio sign in page, try to add the https://www.visualstudio.com/, https://login.microsoftonline.com/ , https://login.live.com/ , https://login.microsoftonline.comto your trusted zone. In the IE, go to Tools -> Internet Options -> Security Tab -> “Sites”, and adds these three sites.

    3. If all the above doesn’t help you, try to enable the JavaScript in IE.

    Go to Tools -> Internet Options-> Security Tab, and then click the Internet zone, depending on whether you have to customize your Internet security settings, select one of the following options:

    •If you do not have to customize your Internet security settings, click Default Level.

    •If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    I hope this was helpful for you..

    Best regards!


    (If this was helpful for you, vote for it and propose it as an answer)

    Monday, March 21, 2016 5:03 AM
  • Hi Almir,

    Thank you for your reply! As you can see I have already tried all those steps before, and I have just made sure once more that my cache and cookies were cleared as you suggested. Unfortunately I'm still unable to sign in. Any other suggestions?

    Thanks:

    Emmet

    Monday, March 21, 2016 5:11 AM
  • Hi Emmet.Mester,

    As the answer mentioned here have you tried to connect using HTTPS: 
    http://answers.microsoft.com/en-us/outlook_com/forum/oaccount-omyinfo/something-went-wrong-and-we-cant-sign-you-in-right/1d2980e5-dcbf-43dd-a80a-8821f5f7ccfe

    To do that, follow the steps below:
    1. Go to https://account.live.com
    2. Under Other options click on Connect with HTTPS
    3. Choose Use HTTPS automatically
    4. Click on Save

    Best regards!


    (If this was helpful for you, vote for it and propose it as an answer)

    Monday, March 21, 2016 5:15 AM
  • Hi Emmet,

    Try to open your IE in InPrivate mode. Open your IE browser, click Ctrl+Shift+P then input the link.

    I am not sure whether it works, but you could try it.

    In addition, please install the latest update of the IE. My IE version is :

    Best Regard,

    Lake Xiao


    Monday, March 21, 2016 6:38 AM
    Moderator
  • Hi Almir,

    I have just tried to find the "Other options" on the Microsoft account page, but it looks like that post was from more than 3 years ago and the account page has changed significantly since then: as far as I can tell the option to "Use HTTPS automatically" doesn't exist anymore.

    Any further suggestions?

    Emmet

    Monday, March 21, 2016 7:35 AM
  • Hi Lake,

    I'm not sure what link are you suggesting I should try in InPrivate mode? I am able to successfully log in to my account on the web - just not from Visual Studio.

    I have verified that I have almost the exact same Internet Explorer version as you do: 11.0.9600.18230. As far as I can tell I cannot update any further (no new updates are offered through Windows Update).

    Any other suggestions?

    Emmet

    Monday, March 21, 2016 7:38 AM
  • Hi Emmet,

    >> I am able to successfully log in to my account on the web - just not from Visual Studio.

    It's so strange and I didn't encounter the same error before. How about using another Microsoft account then try it again?

    In addition, if still no help, since you can sign in it via website. I suppose the cause is still in your Visual Studio. Try to install the VS2015 Update1 the latest update of your Visual Studio.

    In order to check whether the cause is in your VS2015 Community. if possible, I suggest you could install another version of VS like VS2013 Community to check whether it has the same error message when signing it in VS2013.

    Best Regards,

    Lake Xiao

    Monday, March 21, 2016 8:04 AM
    Moderator
  • Hi Lake,

    Sorry for the late reply - I finally got around to clean up some hard disc space and try the procedure with VS2013 Community Edition. Unfortunately the results are still the same.

    Also updated VS2015 to the very latest, still didn't help.

    I'll try another account, will let you know if that helps.

    Emmet

    Monday, April 04, 2016 3:30 AM