BizTalk 2016 and MQ 7.5 no working solution RRS feed

  • Question

  • I am in a bit of a situation where I cannot find a working combination of Biztalk 2016 and MQ (latest mq 7.5). I am migrating/upgrading a customers Bts2010 solution to Bts2016 but the crucial MQ integration part is becoming a headache. 

    I am unable to get the regular COM+ based "MQServer" adapter to work properly. I have installed CU3 on both bts server and MQ server. DTC ping between biztalk and MQ working both ways. 

    Network DTC enabled with correct rights on both servers. firewall is of on both MQ and BTS. When I start a receive port from MQ it is working as expected, files are picked of queue without any issues. Transaction support on receive is on. Receiving from MQ is working in other words.

    Sending to MQ is not working for some reason:

    When I try to put messages on a queue in the same queue manager I rum into errors. If I enable Transactions(which I must do to avoid potential duplicates) I get this error message:

    "A message sent to adapter "MQSeries" on send port "SendPort1_MQS" with URI "MQS://<SERVER>/<QUEUEMANAGER>/<QUEUE>" is suspended.
     Error details: The remote procedure call failed. (Exception from HRESULT: 0x800706BE)

    At the same time I get this error in the event log on the MQ server:

    "Faulting application name: dllhost.exe, version: 6.3.9600.17415, time stamp: 0x54503c46
    Faulting module name: imqs23vn.dll, version: 7.500.200.13275, time stamp: 0x524c4f93
    Exception code: 0xc0000005
    Fault offset: 0x00009fb4
    Faulting process id: 0x1cb8
    Faulting application start time: 0x01d3740fde1ded8d
    Faulting application path: C:\Windows\SysWOW64\dllhost.exe
    Faulting module path: C:\Program Files (x86)\IBM\WebSphere MQ\bin\imqs23vn.dll
    Report Id: 518a2a9a-e003-11e7-80be-005056a10e02
    Faulting package full name:
    Faulting package-relative application ID: "

    If I disable transactions I get the same error on both BizTalk and MQ server, but the message ends up on the queue! The trouble seems to be related to failing transactions Transactions in other words but only when sending and not receiveing!!

    I am lost as to where to start looking to fix this. Any help is greatly appreciated.

    Wednesday, December 13, 2017 1:04 PM

All replies

  • Hello,

    Have you tried to use the MQSC Adapter which is part of Host Integration Server 2016. This one works correctly with the MQ Client 7.5 and 8.0 ?

    Best regards,

    Steve Melan - BCEE My Blog :

    Saturday, December 30, 2017 8:47 PM
  • I'm facing same problem. Did not find any solution as of now. In my case, MQSC adapter working perfectly fine.

    Thanks, Girish R. Patil.

    Monday, January 1, 2018 11:01 AM
  • Hi.

    We have verified with another customers that this most likely must be a bug with BTS 2016 CU3 and MQ 7.5. We have the same issue there where Receive is working fine, but sending to MQ gives us RPC call failed.

    We will try using MQ 8 to see if this does make a difference. 

    MQSC adapter from HIS 2016 is an alternative, but for some reason I am getting XA transaction issues if I enable transactions. HIS 2016 CU2 is installed, XA transactions is enabled on both servers and no firewalls.

    Tuesday, January 2, 2018 10:42 AM
  • Hi,

    We also had a similar problem with BTS2016 and MQ 7.5 but once we updated to MQ 8.1 then we did not have this issue anymore.


    Wednesday, January 3, 2018 7:25 PM
  • I have heard others also having success with upgrading MQ to 8. That unfortunately turned out not to be an option for me as the customer did not want to pay for a new lisence for MQ 8.

    Anyhow, found a solution/work around using MQSC. No straight forward task using MQSC either, but here how I ended up with something that works:

    Install HIS 2016, HIS 2016 CU2, and lastest IBM MQ Client ( Choose to not us MS Client in adapter, then everything works as a charm.

    Using MS Client also works, but not with transactions. If I enabled Transactions with MS Client I got "Failed to enlist in XA Transaction" error, IBM Client does not have this issue.

    I first tried latest 7.5 client ( but that chrashed horribly and disabled the host running the receive location so no point in going there. Use latest MQ Client for MQ 8. 

    Wednesday, January 3, 2018 7:50 PM
  • You can use the MQ Client 8 together with MQ Server 7.0, 7.1, 7.5, 8.0 because the IBM Client is backwards compatible.

    MQSC is the way to go because it is the most stable and supported solution to use IBM MQ within BizTalk Server.

    I'm glad to here that you are using HIS 2016 already with the latest CU2 Package.

    The MS Client = True, allows you to use the Microsoft Client (native), in that case you don't need to install the IBM MQ Client. The only problem is that XA Transactions are not working yet. I hope that this will be fixed with HIS 2016 CU3.

    Please avoid using the 7.5 IBM Client Branch because it still contains a lot of bugs especially in the C++, the C++ interface is used by MQSC in order to communicate with the IBM Client. The 8.0 MQ Client Branch is the way to go.

    Best regards,

    Steve Melan - BCEE My Blog :

    Thursday, January 4, 2018 6:53 AM
  • BizTalk 2016 MQSeries adapter (MQSAgent) use the newer C++ version of the IBM DLLs, which are only available on MQ 8 and later. MQSAgent send operation will fail for MQ 7.5. You have both set of DLLs in MQ 8 (\bin and \bin\vs2005 folders), while in MQ 7.5 you only have \bin with the older DLLs (vs2005). For MQSAgent from older BizTalk version you can use path environment variable to point to \bin\vs2005 to get MQ 8 support.

    So in BizTalk 2016, either use MQSC adapter with IBM client 8 or MS client to communicate with older MQ servers or upgrade MQ to newer version if you want to use MQSeries adapter. MQ 7.5 end of support is 2018-04-30 so may be a good time to upgrade. ( ) 

    Contact me (niklase) if you have issues with MQSC 2016 adapter as we are working on above transaction issue. 

    Friday, February 2, 2018 1:14 PM
  • As you can se we have come to the same conclusion of what works by trial and error and searching on forums such as this.

    For the future it would have been nice if Microsoft would provide information about known errors such as no support for Transactions instead of having each customer having to discover, truouble shoot and dig up the workaround them selves. Having a list of "known defects" is not a new thing, and would have saved me quite some hours of wasted time trying to troubleshoot this issue. 

    Friday, February 2, 2018 1:47 PM
  • It is a recent issue we have found and still working on. We have lots of different cases at Microsoft and it takes time to know exact cause. We will document as usual in upcoming KB articles. If urgent please contact support so we can be made aware and investigate more quickly. 
    Friday, February 2, 2018 4:34 PM
  • For clarity, the MQSC Adapted does support transactions provided you are also using the Extended Transnational Client from IBM.  This has been the case for quite a while.....with one exception.

    We could not get it to work reliably across one particular type of domain boundary...sorry, I don't recall exactly what that way.

    Friday, February 2, 2018 6:05 PM
  • Hi,

    We have a similar issue we have solved major parts but with no ability to use MQMD_Headers for some reason.

    Pleas look att my post here:

    Monday, February 26, 2018 2:32 PM
  • Hi Steve,

    Regarding the comment "The MS Client = True, allows you to use the Microsoft Client (native), in that case you don't need to install the IBM MQ Client. The only problem is that XA Transactions are not working yet. I hope that this will be fixed with HIS 2016 CU3" - that latter point is becoming a major blocker for us now, is there any news on when CU3 might be available please? From what was mentioned at Integrate 2018 at the start of June I'm hoping this isn't far off now!



    Friday, August 24, 2018 2:00 PM
  • Hi,

    I will check with the Product Team. I hope that CU3 will be out soon and that the XA Transactional Support for MQ will be in.

    Other good news : HIS and BizTalk vNext confirmed by the Product Team :-)))))

    Best regards,


    Steve Melan - BCEE My Blog :

    Friday, August 24, 2018 2:06 PM
  • Thanks Steve, much appreciated. I know, great news about vNext!
    Friday, August 24, 2018 3:35 PM
  • Hello, 

    I've got the feedback that the issue is fixed and you could immediately get a private fix by just opening a support case.

    CU3 will contain the fix as well but there's still no release date ...

    Best regards,


    Steve Melan - BCEE My Blog :

    Saturday, August 25, 2018 12:35 PM
  • Hi,

    Just curious, are MS any nearer to a release date for CU3?



    Monday, January 7, 2019 4:11 PM