none
Any version of .NET will not install Server 2003 SP2 RRS feed

  • Question

  • Windows is reporting this is Windows Storage Server 2003 SP2 x64 build 5.2.3790.  I was originally having problems installing the .NET 3.5 SP1 and decided to rip out everything .NET.  I have tried downloading and installing every version i can find and had no luck.  I have ran the verification tools and cleanup tools and everything above .NET 2.0a fails.  I have tried to re-install basic 2.0 from Add/Remove Windows Components and then point it to NetFx64.exe I downloaded but it shuts down, no error or anything.  When Windows Update is ran it shows .NET 3.5 SP1 and Family update (KB951847) x64 and .NET 4 for windows 2003 x64 under optional software, but of course they fail as well.  I have cleaned out and removed the SoftwareDistribution folder and still nothing.  I ran sfc /scannow and everything is good, as well as chkdsk in read only mode.  I have logs everywhere but only say .net is not found.  Im willing to try anything just let me know what you need from me to help

    Thanks!

    Monday, July 8, 2013 8:45 PM

All replies

  • Please run this verification tool to show which (if any) .NET versions are on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with the highest available version selected, then post the first 15 lines AND the LAST 15 lines of the tool log here:

    Also, please provide your install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Wednesday, July 10, 2013 1:33 PM
  • Hello, I know I am not the original poster, but I am having a very serious, very similar problem. Here are the first and last lines of this verifier. I cannot run the install log collector until no one else is logged in to the terminal server. Any help MUCH appreciated.

    [10/04/13,10:36:06] Beginning of new SetupVerifier activity logging session
    [10/04/13,10:36:06] Activity log file location: C:\DOCUME~1\ADMINI~1.SEI\LOCALS~1\Temp\b\setupverifier_main_10-04-13_10.36.06.txt
    [10/04/13,10:36:06] Error log file location: C:\DOCUME~1\ADMINI~1.SEI\LOCALS~1\Temp\b\setupverifier_errors_10-04-13_10.36.06.txt
    [10/04/13,10:36:06] Build created on September 10, 2012
    [10/04/13,10:36:06] Detected operating system: Windows Server 2003 (x64)
    [10/04/13,10:36:06] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [10/04/13,10:36:06] Install state for .NET Framework 1.0: not installed.
    [10/04/13,10:36:06] Install state for .NET Framework 1.1: not installed.
    [10/04/13,10:36:06] Install state for .NET Framework 2.0: installed with service pack 2.
    [10/04/13,10:36:06] Install state for .NET Framework 3.0: installed with service pack 2.
    [10/04/13,10:36:06] Install state for .NET Framework 3.5: installed with service pack 1.
    [10/04/13,10:36:06] Install state for .NET Framework 4 Client: not installed.
    [10/04/13,10:36:06] Install state for .NET Framework 4 Full: not installed.
    [10/04/13,10:36:06] Install state for .NET Framework 4.5: not installed.
    [10/04/13,10:36:06] Windows directory: C:\WINDOWS
    [10/04/13,10:36:06] System directory: C:\WINDOWS\system32
    [10/04/13,10:36:06] Program Files directory: C:\Program Files (x86)
    [10/04/13,10:36:06] Common Files directory: C:\Program Files (x86)\Common Files
    [10/04/13,10:36:06] Not adding product '.NET Framework 1.0' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 1.1' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 2.0' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 3.0' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 3.5' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 4 Client' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 4 Full' because it is not currently installed
    [10/04/13,10:36:06] Not adding product '.NET Framework 4.5' because it is not currently installed

    -------------------------------------------------------------------------------

    [10/04/13,10:36:23] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - stop parsing entries
    [10/04/13,10:36:23] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [10/04/13,10:36:23] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [10/04/13,10:36:23] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [10/04/13,10:36:23] ExecutablePath = 'Netfx20TestApplication.exe'
    [10/04/13,10:36:23] FriendlyName = '.NET Framework 2.0 test application'
    [10/04/13,10:36:23] TimeoutSeconds = '300'
    [10/04/13,10:36:23] WaitOnExit = 'true'
    [10/04/13,10:36:23] Silent = 'true'
    [10/04/13,10:36:23] Launching process 'Netfx20TestApplication.exe' now
    [10/04/13,10:36:23] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/04/13,10:36:26] Process 'Netfx20TestApplication.exe' exited with return code 0
    [10/04/13,10:36:26] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [10/04/13,10:36:26] Verification succeeded for product .NET Framework 3.5 SP1

    Thank you.

    I am unable to install any .NET products.

    Friday, October 4, 2013 2:47 PM
  • Hello, Stephen.

    The verifier shows .NET Framework 2.0/3.0/3.5 with latest service packs installed and verified.

    To help you, we need to know which .NET Framework version(s) you are attempting to install and we need the full log set for analysis.

    Saturday, October 5, 2013 4:59 AM
  • Hello,

    Thanks for your response. I am trying to install Windows updates for any of these .NET versions and they download just fine, and upon the installation, just hand there with no progress for up to an hour until I cancel them. I have tried several different updates, always the same. Other updates (not pertaining to .NET) seems to install fine. I also cannot install C++ updates.

    Is there an email address I can send the log to?

    Thanks for your help.

    Monday, October 7, 2013 12:52 PM
  • In that case (updates to .NET Frameworks fail), you need to verify the .NET Frameworks currently installed.

    Using the verification tool you downloaded previously, run it with each version selected (2.0, 3.0 and 3.5), then post the LAST 15 lines of each log here.

    These runs will tell us if the installed frameworks are corrupt.

    For help with C++ updates (unrelated to .NET Framework), please ask here:

    http://social.msdn.microsoft.com/Forums/en-US/vssetup/threads

    Monday, October 7, 2013 2:45 PM
  • This is the verifier result from .NET 2.0:

    Last 15 lines:

    [10/07/13,10:52:54] Not running action 'Registry GE - .NET Framework 2.0 SP2 (32-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [10/07/13,10:52:54] Section [Registry GE - .NET Framework 2.0 SP2 (64-bit)] - start parsing entries
    [10/07/13,10:52:54] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
        Value: SP
        Expected Data:    2
        Actual Data:    2
    [10/07/13,10:52:54] Section [Registry GE - .NET Framework 2.0 SP2 (64-bit)] - stop parsing entries
    [10/07/13,10:52:54] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [10/07/13,10:52:54] ExecutablePath = 'Netfx20TestApplication.exe'
    [10/07/13,10:52:54] FriendlyName = '.NET Framework 2.0 test application'
    [10/07/13,10:52:54] TimeoutSeconds = '300'
    [10/07/13,10:52:54] WaitOnExit = 'true'
    [10/07/13,10:52:54] Silent = 'true'
    [10/07/13,10:52:54] Launching process 'Netfx20TestApplication.exe' now
    [10/07/13,10:52:54] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/07/13,10:52:54] Process 'Netfx20TestApplication.exe' exited with return code 0
    [10/07/13,10:52:54] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [10/07/13,10:52:54] Verification succeeded for product .NET Framework 2.0 SP2

    Here is the verifier log from 3.0

    last 15 lines:

    [10/07/13,10:54:28] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0
        Value: Install
        Expected Data:    1
        Actual Data:    1
    [10/07/13,10:54:28] Section [Registry GE - .NET Framework 3.0 SP2 (Wow6432Node)] - stop parsing entries
    [10/07/13,10:54:28] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [10/07/13,10:54:28] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [10/07/13,10:54:28] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [10/07/13,10:54:28] ExecutablePath = 'Netfx20TestApplication.exe'
    [10/07/13,10:54:28] FriendlyName = '.NET Framework 2.0 test application'
    [10/07/13,10:54:28] TimeoutSeconds = '300'
    [10/07/13,10:54:28] WaitOnExit = 'true'
    [10/07/13,10:54:28] Silent = 'true'
    [10/07/13,10:54:28] Launching process 'Netfx20TestApplication.exe' now
    [10/07/13,10:54:28] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/07/13,10:54:28] Process 'Netfx20TestApplication.exe' exited with return code 0
    [10/07/13,10:54:28] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 3.0 SP2' because the OS condition does not match
    [10/07/13,10:54:28] Verification succeeded for product .NET Framework 3.0 SP2

    And, here is the result from 3.5:

    Last 15 lines:

    [10/07/13,10:55:56] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5
        Value: SP
        Expected Data:    1
        Actual Data:    1
    [10/07/13,10:55:56] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - stop parsing entries
    [10/07/13,10:55:56] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [10/07/13,10:55:56] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [10/07/13,10:55:56] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [10/07/13,10:55:56] ExecutablePath = 'Netfx20TestApplication.exe'
    [10/07/13,10:55:56] FriendlyName = '.NET Framework 2.0 test application'
    [10/07/13,10:55:56] TimeoutSeconds = '300'
    [10/07/13,10:55:56] WaitOnExit = 'true'
    [10/07/13,10:55:56] Silent = 'true'
    [10/07/13,10:55:56] Launching process 'Netfx20TestApplication.exe' now
    [10/07/13,10:55:56] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/07/13,10:55:56] Process 'Netfx20TestApplication.exe' exited with return code 0
    [10/07/13,10:55:56] Not running action 'Files - .NET Framework netfxperf.dll' for product '.NET Framework 3.5 SP1' because the OS condition does not match
    [10/07/13,10:55:56] Verification succeeded for product .NET Framework 3.5 SP1

    Monday, October 7, 2013 2:56 PM
  • Your .NET 2.0/3.0/3.0 verifies as correctly installed and configured.

    Now we need to dig into the details of the update failures. For that, we need to know which updates failed and to examine the install logs.

    Please provide logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Monday, October 7, 2013 3:20 PM
  • Getting error "this is not a valid win32 application"

    Is there a 64-bit version I need?

    Monday, October 7, 2013 3:24 PM
  • Is this from Collect.exe?

    Are you running it with full administrative rights?

    The utility works on all systems, IME. Out of hundreds of users, I've never seen an issue with it.

    Monday, October 7, 2013 4:04 PM
  • http://i44.tinypic.com/2ufzwpi.jpg

    I am running as domain admin. Any ideas?

    Monday, October 7, 2013 4:16 PM
  • You can try downloading Collect.exe from the link in this article, and also read the article part that addresses issues running the utility:

    http://blogs.msdn.com/b/astebner/archive/2007/08/01/4172276.aspx

    Tuesday, October 8, 2013 12:48 PM