locked
HTTP Error 500.19 - Internal Server Error RRS feed

  • Question

  • User-1499457942 posted

    Hi

      I am getting above error . I am running directly from Visual Studio 2012

    <div id="content"> <div class="content-container">

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    </div> <div class="content-container">

    <fieldset>

    Detailed Error Information:

    <div id="details-left">
    Module    IIS Web Core
    Notification    Unknown
    Handler    Not yet determined
    Error Code    0x800700b7
    Config Error    Config section 'system.web/compilation' already defined. Sections must only appear once per config file. See the help topic <location> for exceptions
    Config File    \\?\c:\users\Test\documents\visual studio 2012\Projects\Test\web.config
    </div> <div id="details-right">
    Requested URL    http://localhost:2315/Index.aspx
    Physical Path    
    Logon Method    Not yet determined
    Logon User    Not yet determined
    Request Tracing Directory    C:\Users\Test\Documents\IISExpress\TraceLogFiles\
    <div class="clear"></div> </div></fieldset>

    </div> <div class="config_source content-container">

    <fieldset>

    Config Source:

       22: 		<httpRuntime maxRequestLength="1048576" executionTimeout="3600"/>
       23: 		<compilation debug="true"/>
       24: 	</system.web>
    
    </fieldset>

    </div> </div>

    Thursday, June 21, 2018 5:41 AM

Answers

  • User-1499457942 posted

    Hi

      Resolved by adding below lines in Web.Config

    <system.webServer>
            <validation validateIntegratedModeConfiguration="false"/>
        </system.webServer>

    Thanks
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 21, 2018 6:04 AM

All replies

  • User-1499457942 posted

    Hi

      After removing this line - 

    <compilation debug="true"/>

    i am getting below error now

    HTTP Error 500.22 - Internal Server Error

    An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

    <fieldset>

    Most likely causes:

    • This application defines configuration in the system.web/httpModules section.
    </fieldset>
    <fieldset>

    Things you can try:

    • Migrate the configuration to the system.webServer/modules section. You can do so manually or by using AppCmd from the command line. For example, from the IIS Express install directory, run appcmd migrate config "Default Web Site/". Using AppCmd to migrate your application will enable it to work in Integrated mode. It will continue to work in Classic mode and on previous versions of IIS.
    • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
    • Alternatively, switch the application to a Classic mode application pool. For example, from the IIS Express install directory, run appcmd set app "Default Web Site/" /applicationPool:"Clr4ClassicAppPool". Only do this if you are unable to migrate your application.
    </fieldset>
    <fieldset>

    Detailed Error Information:

    Module    ConfigurationValidationModule
    Notification    BeginRequest
    Handler    PageHandlerFactory-Integrated-4.0
    Error Code    0x80070032
    Requested URL    http://localhost:2315/Index.aspx
    Physical Path    c:\users\test\documents\visual studio 2012\Projects\test\Index.aspx
    Logon Method    Not yet determined
    Logon User    Not yet determined
    Request Tracing Directory
    <fieldset>
    C:\Users\Test\Documents\IISExpress\TraceLogFiles\Test
    </fieldset>
    </fieldset>

    Thanks

    Thursday, June 21, 2018 5:59 AM
  • User-1499457942 posted

    Hi

      Resolved by adding below lines in Web.Config

    <system.webServer>
            <validation validateIntegratedModeConfiguration="false"/>
        </system.webServer>

    Thanks
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 21, 2018 6:04 AM