none
!address requires private symbols? RRS feed

  • Question

  • I couldn't find a forum for the debuggers, so I'm posting here; hopefuly someone can help.

    I'm trying some commands in windbg, like !address -summary or !heap -s and I get the error message below. My sympath is pointing to MS symbol server and running the lm command I can see that ntdll symbols are loaded correctly.

    I understand that the message below tells me that these commands require private symbols but I have been using them for quite some time and they worked fine with public symbols. Did something change or am I missing something?

    Here is what I get:

    0:031> !address -summary
    *************************************************************************
    ***                                                                   ***
    ***                                                                   ***
    ***    Either you specified an unqualified symbol, or your debugger   ***
    ***    doesn't have full symbol information.  Unqualified symbol      ***
    ***    resolution is turned off by default. Please either specify a   ***
    ***    fully qualified symbol module!symbolname, or enable resolution ***
    ***    of unqualified symbols by typing ".symopt- 100". Note that   ***
    ***    enabling unqualified symbol resolution with network symbol     ***
    ***    server shares in the symbol path may cause the debugger to     ***
    ***    appear to hang for long periods of time when an incorrect      ***
    ***    symbol name is typed or the network symbol server is down.     ***
    ***                                                                   ***
    ***    For some commands to work properly, your symbol path           ***
    ***    must point to .pdb files that have full type information.      ***
    ***                                                                   ***
    ***    Certain .pdb files (such as the public OS symbols) do not      ***
    ***    contain the required information.  Contact the group that      ***
    ***    provided you with these symbols if you need this command to    ***
    ***    work.                                                          ***
    ***                                                                   ***
    ***    Type referenced: ${$ntdllsym}!_PEB                             ***
    ***                                                                   ***
    *************************************************************************

    No symbols for ntdll. Cannot continue.

    and here is lm showing the symbols loaded:

    77e30000 77fb0000   ntdll      (pdb symbols)          d:\symbolsms\wntdll.pdb\BBB0846A402C4052A16B67650BBFE6B02\wntdll.pdb

    Wednesday, September 16, 2015 7:25 PM