none
Problems installing .NET framework RRS feed

  • Question

  • Hi all,

    Recently I began getting a message when I logged in that a service I use could not load because of a "corrupted .NET" file or something. I tried installing the newest version but this didn't fix the problem and I still could not access the service.

    I use Aaron Stebner's cleanup tool then. Now I cannot even install .NET. I keep getting a fatal error message.

    Here is the log information from the failed install....

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\0fd9d181d3f1bd1e8e679fa96c7ad0c3\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = Eastern Daylight Time
    Initial LCID = 4105
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 11
    Exe (C:\0fd9d181d3f1bd1e8e679fa96c7ad0c3\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\Users\Lisa\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (C:\0fd9d181d3f1bd1e8e679fa96c7ad0c3\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (C:\Users\Lisa\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120314_095644457-MSI_netfx_Core_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:40).

    Wednesday, March 14, 2012 2:19 PM

Answers

  • First, can you tell us what .NET Framework version the service in question requires?

    If you did not have .NET Framework 4.0 installed prior to the error appearing, 4.0 is not the issue (nor is it the cure).

    Your Windows 7 comes with .NET Framework version 2.0/3.0/3.5 (AKA .NET Framework 3.5.1) installed as part of the OS. Aaron Stebner's tool will not touch those versions.

    If you wish to verify 3.5.1, use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx 

    Post the first 15 lines and last 15 lines of tool output here.

    If you want to retry installing .NET Framework 4.0. you should follow these steps exactly:

    You can also try this sequence:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Wednesday, March 14, 2012 4:00 PM