locked
accessing ws_metadata exchange failure RRS feed

  • Question

  • Hi,

    I am trying to run the azurestack install powershell and i am getting the following error. I have an AAD user and i use those creds in the process when it prompts me.

    Get-AADToken : Exception calling "AcquireToken" with "3" argument(s): "accessing_ws_metadata_exchange_failed: Accessing WS metadata
    exchange failed"
    At C:\CloudDeployment\Common\AzureADConfiguration.psm1:131 char:14
    + ...    $token = Get-AADToken -ResourceUri $AzureURIs.ManagementServiceUri ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Get-AADToken], MethodInvocationException
        + FullyQualifiedErrorId : AdalServiceException,Get-AADToken

    Can anyone help me get it installed. I figure its something simple i am missing.

    Thanks,

    Paul hacker


    Tuesday, September 27, 2016 11:51 PM

All replies

  • Paul - Did you check the prerequisites before you start deploying Azure Stack POC TP2? Can you please read through this doc and ensure that all prerequisites are met, before attempting to deploy Azure Stack POC TP2? https://azure.microsoft.com/en-us/documentation/articles/azure-stack-deploy/

    Also, which Azure environment does your AAD account have access to? If it's not "Public Azure", you'll need to specify your Azure environment by using the "-AzureEnvironment" parameter. Check out this doc for all parameters: https://azure.microsoft.com/en-us/documentation/articles/azure-stack-run-powershell-script/

    Thanks,

    Cheng


    Cheng Wei [MSFT] - Posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, September 28, 2016 3:13 AM