none
Passing "actions" RRS feed

  • Question

  • Hi,

    I am trying to configure WCF-custom to work with echo sample adapter.
    I am passing Actions as describied in this post
    http://www.cubido.at/Blog/tabid/176/EntryID/127/Default.aspx which in turn refers Sonu Arora blog...

    So I added the following entry into machine.config
     <add name="myInboundElement" type="Microsoft.ServiceModel.Channels.InboundActionElement, Microsoft.ServiceModel.Channels, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    But..
    When I am configuring WCF-custom and trying to add myInboundElement to EndPointBehvior in the "Behavior" tab, the "Configuration" panel on the right remains empty.
    So on the left panel I have "myInboundElement", but in the right panel I can't specify neither delimiter, nor actions.
    Any ideas what could be wrong ? 
    I spent a whole day and still can't figure this out and still nothing... I am running BTS2009 beta, and WCF LOB SDK 2.0

    Thanks a lot !
     
    Monday, April 6, 2009 4:11 AM

Answers

All replies

  • Hi,

    You have mentioned that you're using WCF LOB Adapter SDK 2.0, while the steps you have followed to register/use your adapter are specific to ASDK V 1.0..
    Ensure that you have followed the tutorial for the correct version of ASDK.

    Thanks,
    Manas
    Monday, April 6, 2009 10:43 AM
  • Hi there,

    I'm not sure whether I understood your procedure and your problem correctly. But when I went through the blog you
    mentioned , it says the action should be specified as: "Echo/OnReceiveEcho". Try setting this action and reply whether it works or not.

    Thanks
    Gaurav
    Monday, April 6, 2009 10:43 AM
  • I guess you are writing your own EndpointBehavior as described in http://blogs.msdn.com/adapters/archive/2008/01/18/how-to-obtain-a-list-of-receive-actions-when-an-asdk-based-adapter-is-used-with-biztalk-in-a-receive-location.aspx.
    If that is the case, while registering in machine.config you have to specify the Dll containing your custom EndPointBehavior in the type attribute.

    <add name="myInboundAction" type="MyInboundActionElement, ASSEMBLY(DLL)_NAME_HERE, Version=1.0.0.0, Culture=neutral, PublicKeyToken=PUBLIC_KEY_TOKEN_HERE" />

    Hope this helps.

    Thanks,
    Jeevitha

    • Proposed as answer by Jeevitha - MSFT Monday, April 6, 2009 11:37 AM
    • Marked as answer by fly2 Monday, April 6, 2009 12:16 PM
    Monday, April 6, 2009 11:37 AM
  • >>Try setting this action
    That's exactly what I am asking - I am trying to set the action, with not much luck unfortunately
    Monday, April 6, 2009 11:50 AM
  • That's exactly what I have done. 

    I added the following entry into machine.config
    <add name="myInboundElement" type="Microsoft.ServiceModel.Channels.InboundActionElement, Microsoft.ServiceModel.Channels, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

    The problem is that when I added it to EndPointBehavior on "Behavior" tab upon configuring WCF-custom, I was unable to specify neither delimiter nor actions. For some  unknown reason they didn't show up in the "Configuration" panel. The panel is empty

    Thanks !


    Monday, April 6, 2009 11:54 AM
  • I am not sure if I got what you meant...

    As far as ASDK documentation concerned, I followed the one supplied with WCF LOB SDK V.20, which BTW uses "actions" in the walkthrough code, but the doc. doesn't say a word about how to configure WCF-custom to use those actions. So I had exactly the same problem as described in the blog I mentioned in the original post - the adapter boots out incoming messages.

    I googled on this, I found that blog and as it suggested I put the following element in machine.config to configure "actions" in WCF custom.
    <add name="myInboundElement" type="Microsoft.ServiceModel.Channels.InboundActionElement, Microsoft.ServiceModel.Channels, Version=3.0.0.0, Culture=neutral, IPublicKeyToken=31bf3856ad364e35" />
    But I am unable to specify delimiters and actions for some reason upon configuring WCF-custom.

    If it is different for ASDK 2.0, where I can find the documentation and what exactly changed as far as adapter usage and registration concerned?

    Thanks !

    Monday, April 6, 2009 12:09 PM
  • OMG, I didn't notice that I had to write my own component. I just followed Sonu Arora's blog.  Thanks a lot, I see what I have missed.  
    But that raised the question of the quality of the documentation supplied with the product. Though it is a different story...

    Thanks a lot !
    Monday, April 6, 2009 12:16 PM
  • http://blogs.msdn.com/adapters/archive/2008/01/18/how-to-obtain-a-list-of-receive-actions-when-an-asdk-based-adapter-is-used-with-biztalk-in-a-receive-location.aspx has a sample InboundEndpointBehavior element in the attachment, which will guide how to add custom behaviorextensions.
    Monday, April 6, 2009 12:33 PM