none
I have a bug trying to install .NET 4.5 RRS feed

  • Question

  • NOTE: I was getting assistance from someone, but he seems to have disappeared, so I am starting a new thread.

    I have Windows 7 Home Premium, SP1.

    I am trying to install .NET 4.5 via dotnetfx45_full_x86_x64.exe and I keep getting a strange error.

    The account I'm logged in as, Jean, is already being run as an Administrator, and when I tried to change the account type, the selection of the Administrator radio button made it such that the Change Account Type button would be disabled.

    Here is the vslogs.cab file from the vscollect app (I renamed it vslogs_2 as I have an earlier one there.)  

    http://sdrv.ms/1atReyO

    Wednesday, September 18, 2013 12:49 AM

All replies

  • Hi Swampwiz,

    I found that your another case about the .NET 4.5 installation failed issue. You got the error message:
    Returning IDOK. INSTALLMESSAGE_ERROR [Could not write value Locale to key \SOFTWARE\Microsoft\Active Setup\Installed Components\{1AD147D0-BE0E-3D6C-AC11-64F6DC4163F1}. Verify that you have sufficient access to that key, or contact your support personnel.]

    You may got this error as you do not have required permissions. Although you stated that the user account you’re using already have the administrator permissions, I would like you to do the following things to double check it:

    1. Please run with administrator privileges - Right-click the installer >> "Run as Administrator"
    2. Make sure the user account is a member of the Administrators group.
    3. In the Regedit.exe, find the {1AD147D0-BE0E-3D6C-AC11-64F6DC4163F1} key, right-click it -> choose Permissions->Add the user account (Jean)->Grant him Full Control permission.

    In addition, please also close antivirus program before install .net Framework 4.5.

    Hope these help.


    Lilia Gong <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, September 18, 2013 9:50 AM
    Moderator
  • Hi Swampwiz,

    The download that you have may be the lightweight installer, can you try this link to the full download? It might help with your issue.

    http://download.microsoft.com/download/b/a/4/ba4a7e71-2906-4b2d-a0e1-80cf16844f5f/dotnetfx45_full_x86_x64.exe


    Regards,

    Stacy


    Wednesday, September 18, 2013 10:05 AM
  • I'm still getting this error with that GUID.  Here is a link to the vslogs.cab file.

    http://sdrv.ms/1drDWUC

     I downloaded and ran (as Administrator) that install file, even though it seemed to be the same as the one I had been using. I turned off all the anti-virus programs that are shown running on the taskbar.

    When I go to Control Panel\All Control Panel Items\User Accounts, it shows the user as my name, then "Administrator" & password protected. I am not sure how to "make sure the user account is a member of the Administrators group".

    The entry for that GUID in regedit is such that for all 4 users, the Allow checkbox is checked and is also disabled for all except RESTRICTED, in which the checkbox is enabled.

    Perhaps I should just delete that GUID entry?  FWIW, there is only one entry there, which is (Default), REG_SZ, (value not set).




    • Edited by swampwiz_ Thursday, September 19, 2013 2:00 PM
    Thursday, September 19, 2013 12:00 PM
  • Hi swampwiz,

    Let's focus on this newly created case.

    Thanks.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Tuesday, September 24, 2013 6:48 AM
    Moderator