locked
Error in Web site administraion tool RRS feed

  • Question

  • User-1987530657 posted

    Once i click at ASP.NET configration icon in solution explorer i got error message say :

    An error was encountered. Please return to the previous page and try again.  !!!!

    after a littel   search i figured out its not related to the applicatiopn in due to error in the site of the WAT it self any way ,any one know how to overcome this strange error ?

    why it

    Tuesday, May 13, 2008 12:28 PM

All replies

  • User1397122928 posted

    Have you installed SQL Server 2005 Express? Or did you insert a custom membership provider into web.config.

    If you open it the first time the admin tool tries to create a membership database in your app_data folder. 

    Tuesday, May 13, 2008 3:36 PM
  • User-1987530657 posted

    well , I use sql server 2005 , i didn t add any custom membership Providers at all im simply downlaod the site and installed it then try to add new user and roles but useless the WAT dosnt work to me !

    -My app_data folder only contianes the TimeTracker.mdf/LDF files and  copy TimeTracker.mdf DB as bauckup. thats all

    Wednesday, May 14, 2008 2:52 AM
  • User1397122928 posted

     Could you shourtly check your memberhship configuration in the web.config file. There should be an entry like this which is pointing to the timetracker database

    <membership>
          <providers>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />
          </providers>
        </membership>

    So I think the problem is that the database is not linked with the project correctly. So it can't find any user datas. Maybe you can post your web.config so I can take a look on it. 

    Wednesday, May 14, 2008 11:50 AM
  • User555306248 posted

    1) in VWD create a new Web Site and point it directly to your IIS local web server call it TimeTracker e.g. http://localhost/TimeTracker (since I have problem getting VWD web server to work using the Beta release) this step will create a web site on your local IIS, you can do this manually too.
    2) Unzip the file downloaded into the C:\Inetpub\wwwroot\TimeTracker and overwrite any files there.
    3) Launch the site in IE e.g. http://localhost/TimeTracker/Default.aspx

    Check in web.config for connectionString, configure it according to your server name, password etc.

    In Time Tracking System, it uses inbuild Membership classes for user creation, updation etc..

    You have to register your DB with ASP.NET Membership classes by executing the command line utility in VS prompt

    aspnet_regsql, it will open one window, where you  have to configure DB.

    If this helpful to you please mark it as answer, So it will help for other people 

    Hope it will help you, let me know.

    Wednesday, May 14, 2008 11:18 PM
  • User-1987530657 posted

    hi ArminStrockner

    this is my web.config :

    <?xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <connectionStrings>

    <!--

    <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=.;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=.;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true"/>

    -->

    <
    add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=(local);Integrated Security=True;Initial Catalog=Issues_Tracker"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=(local);Integrated Security=True;Initial Catalog=Issues_Tracker"/>

    </connectionStrings>

    <system.web>

    <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <clear/>

    <add name="AspNetXmlSiteMapProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>

    </providers>

    </siteMap>

    <authentication mode="Forms">

    <forms loginUrl="~/TimeTracker/login.aspx"/>

    </authentication>

    <compilation debug="true"/>

    <customErrors mode="RemoteOnly"/>

    <machineKey decryptionKey="AutoGenerate,IsolateApps"/>

    <roleManager enabled="true"/>

    </system.web>

    </configuration>

     

    Thursday, May 15, 2008 3:07 AM
  • User1397122928 posted

     Hmm I think your membership tool is not linked with the database so do the following. Insert this into your web.config under system.web:

    <membership defaultProvider="myMembershipProvider">
          <providers>
            <add name="myMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="aspnet_staterKits_TimeTracker" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />
          </providers>
        </membership>

    This will link your application with the timetracker DB because I think the users are handled there. 

    Thursday, May 15, 2008 10:22 AM
  • User555306248 posted

    Try to register sql server with ASP.NET using aspnet_regsql

    also register iis using aspnet_regiis -i

    Add custom membership provide in web.config

    Let me know if this helpful to you

    Sunday, May 18, 2008 11:26 PM
  • User-1987530657 posted

    hi this is the web.config after change still not working :

    <?
    xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <connectionStrings>

    <!--

    <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=.;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=.;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true"/>

    -->

    <
    add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=(local);Integrated Security=True;Initial Catalog=Issues_Tracker"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=(local);Integrated Security=True;Initial Catalog=Issues_Tracker"/>

    <membership defaultProvider="myMembershipProvider">

    <providers>

    <add name="myMembershipProvider"

    type="System.Web.Security.SqlMembershipProvider,

    System.Web, Version=2.0.0.0, Culture=neutral,

    PublicKeyToken=b03f5f7f11d50a3a
    " connectionStringName="aspnet_staterKits_TimeTracker"

    enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />

    </providers></membership>

     

     

    </
    connectionStrings>

    <system.web>

    <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <clear/>

    <add name="AspNetXmlSiteMapProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>

    </providers>

    </siteMap>

    <authentication mode="Forms">

    <forms loginUrl="~/TimeTracker/login.aspx"/>

    </authentication>

    <compilation debug="true"/>

    <customErrors mode="RemoteOnly"/>

    <machineKey decryptionKey="AutoGenerate,IsolateApps"/>

    <roleManager enabled="true"/> </system.web>

    </configuration>

    Monday, May 19, 2008 4:07 AM
  • User-1987530657 posted

    HI chetan

    after all transfered the project under wwwroot and the wat tool worked ok for me after all when i start the application i got this error

    Login failed for user 'OIMDOKITAN01\ASPNET'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: Login failed for user 'OIMDOKITAN01\ASPNET'.

    Source Error:

    Line 11:         if (Roles.Enabled)
    Line 12:         {
    Line 13:             if (!Roles.RoleExists("ProjectAdministrator"))
    Line 14:             {
    Line 15:                 Roles.CreateRole("ProjectAdministrator");


    Source File: c:\Inetpub\wwwroot\TimeTracker_AD\Global.asax    Line: 13

     

     why !?

    Monday, May 19, 2008 7:06 AM
  • User1397122928 posted

    Hmm maybe this article helps you out:

    http://weblogs.asp.net/coltk/archive/2003/07/10/9920.aspx 

    Monday, May 19, 2008 10:42 AM
  • User555306248 posted

    Open SQL Server Managemnet Studio

    Go to Security on left tab panel - > Add machinename/aspnet user & give full rights to it

    Monday, May 19, 2008 11:27 PM