locked
Crystal Report Loading Issue.. RRS feed

  • Question

  • User-1379963870 posted

    i have deploy crystal report at live server. That report working properly at my place local mahine

    when i upload over live server it is asking me for server login detail so i have write code as per below

    Dim i As Integer
                Dim LogonInfo As String()
                Dim Server As String = "", Database As String = "", User As String = "", Pwd As String = ""
                LogonInfo = ConfigurationManager.ConnectionStrings("ConnectionString").ConnectionString.Split(";")
                For i = 0 To LogonInfo.Length - 1
                    Dim strTemp As String() = LogonInfo(i).Split("=")
                    Select Case strTemp(0).ToLower()
                        Case "server"
                            Server = strTemp(1)
                            Exit Select
                        Case "database"
                            Database = strTemp(1)
                            Exit Select
                        Case "user id"
                            User = strTemp(1)
                            Exit Select
                        Case "password"
                            Pwd = strTemp(1)
                            Exit Select
                    End Select
                Next
                CRViewer.ReportSource = rptName

                Dim myConnectionInfo As ConnectionInfo = New ConnectionInfo()
                myConnectionInfo.DatabaseName = Database
                myConnectionInfo.UserID = User
                myConnectionInfo.Password = Pwd
                myConnectionInfo.IntegratedSecurity = True
                Dim myTableLogOnInfos As TableLogOnInfos = CRViewer.LogOnInfo()
                For Each myTableLogOnInfo As TableLogOnInfo In myTableLogOnInfos
                    myTableLogOnInfo.ConnectionInfo = myConnectionInfo
                Next

    Still it is askind for credential so plz give me solution for this....


     

     

    Monday, August 6, 2012 8:20 AM

All replies

  • User-578610739 posted

    Hi Esha,

    Please check that you not save your report as "Save with data" option in file menu, then untick and save.

    Also If it is possible than you check give live database credential to report and save it and deploy again.

    Still if you have problem. then check your live database credentials.

    see below link.

    http://forums.asp.net/t/1647609.aspx/1

    http://stackoverflow.com/questions/4801835/crystal-report-credentials-prompt-after-deployment

    Monday, August 6, 2012 9:31 AM
  • User-1379963870 posted

    Hi Ajay,

    Please check that you not save your report as "Save with data" option in file menu, then untick and save

    Where i will find this option..??? in file menu i didnt get any such option.

    Also If it is possible than you check give live database credential to report and save it and deploy again.

    Can you tell me how i will change report credential ?? from export Database option.. ??

     

    Tuesday, August 7, 2012 3:12 AM
  • User-578610739 posted

    Hi Esha,

    See link,

    Step by Step Tips - Changing data source and database

    http://www.softwareforces.com/Support/Learning-Center/Step-by-Step/rpt-Inspector/Changing-Data-source-and-Database-Crystal-Reports-Dev-to-QA-to-Production

    Tuesday, August 7, 2012 5:53 AM
  • User-1379963870 posted

    HI..

    How to assign credential so subreport in crystal report. (in vb.net )

    please share code.. i m facing problem in this..

     

    Tuesday, August 7, 2012 9:19 AM
  • User-1379963870 posted

    Help me out on this....

    Wednesday, August 8, 2012 1:34 AM
  • User-2087874776 posted

    I  have same issue ...  your answers did not help me... please help me

    Wednesday, August 8, 2012 1:40 AM